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CASLide Overview 
The CASL Interactive Development Environment (CASLide) turns your Windows PC 
into a “workbench” on which you can create, test, and modify the CASL applications 
you build for your PalmPilot. Every step of the process, from idea to application, can 
be performed from within the development environment.  

CASLide provides a multi-windowed editing facility, allowing you to work on more than 
one CASL source file simultaneously.  This allows you to not only create programs 
from scratch, but to cut and paste source code from other CASL programs that you’ve 
written, or downloaded from the CASLsoft web page. 

CASLide also provides a forms builder that allows you to construct user interfaces for 
your application buy selecting CASL display objects (buttons, text boxes, etc.) from a 
tool bar and dropping them on the display form. The display objects can be moved and 
resized using the mouse. 

CASLide allows you to invoke the CASL compiler, to check for syntax errors (in the 
early stages of a program’s life) or to generate p-code, for execution on the Windows 
PC, PalmOS device or PocketPC device.  As compile errors are encountered, they are 
displayed in a fully dockable sub-window, in such a way that if the error messages are 
double clicked, the associated error in the CASL source file will be positioned to and 
marked. 

For applications that you wish to distribute publicly or simply wish to appear on the 
PalmPilot’s main screen, CASLide provides a tool that allows you to convert the CASL 
compiler’s p-code output into a PalmPilot “program resource” file (*.PRC file).  This 
feature requires the selection of a CREATOR ID and desktop name for unique 
identification as a PalmPilot application. 

After successful testing on your Windows PC, CASLide also allows you to install your 
application for download in the Palm or PocketPC device. 

In the chapters that follow, these features are discussed in more detail, to provide you 
with the tools necessary to get started on your first CASL application for your 
PalmPilot. 
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What’s New In CASLide 4.3 
Changes from CASLide Version 4.1 & 4.2: 

 High Resolution forms, bitmaps and icons for PalmOS 

 ActiveSync support for PocketPC 

 Added two transfer utilities, CASLcdi2ppc and CASLppc2cdb to allow one-way 
transfers of CASL databases to the PC/Desktop. 

 Improved support for CASL Setup on Windows Mobile 5 devices. 

 By pressing CTL+SPACE within the CASL 4.3 IDE, a new function, object, and 
global variable browser will appear.  This will allow you to easily see the 
functions, parameters and return value data types. 

 When compiling applications, CASL will now show the number of CASL objects 
in the build window (Example: 'Total Number CASL Objects = 125').  If the 
number of objects  within the CASL application exceeds the maximum number 
allowed (644) an error will be generated. 
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CASLide User Interface 
There are a number of ways that you can control the operation of CASLide: 

Pressing control, Alt, and shortcut key sequences. 

Using the command toolbar Icons. 

Selecting a command from the menu bar. 

Only the menu bar provides full access to the capabilities of the CASLide, the key 
sequences and command toolbar Icons exist to provide shortcuts to the most 
frequently used commands.  Therefore, the sections below describe each CASLide 
feature as encountered in the menu hierarchy.  Where appropriate, the shortcut key 
sequence or toolbar Icon that also invoke the feature will be mentioned in the 
command description. 

Highlighting a keyword and pressing F1 can display context help for a CASL language 
keyword. 

Clicking in the gutter (left most grey'd column) will select the line and Insert/Overwrite 
can be toggled by Insert key. 

The display supports multiple, syntax colored text editor windows, which in turn can 
have multiple and split views. The display also shows user interface forms, as they 
would appear while the application is running. 

There is also a project widow, which is shown as a “tree view”, and output view to 
show the results of the build, and variable values. The project and output views can be 
“docked” to any side of the IDE window, or detached. Likewise, the tool bars can be 
positioned allowing the developer to customize the layout of CASLide. 

You can double click on an icon in the project tree to open the file or click the right 
mouse button to display a context menu, which has many helpful functions. 

You can double click on a line in the compiler output window to position the cursor to 
the line that had a syntax error. 

A project is a collection of source files, package files, form files, and ICON that 
makeup the application. The project files, settings, and more are saved as a project 
thus allowing customization on a project-by-project basis. 
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CASLide Menus, Toolbars, and Views 
The main menu bar of CASL IDE categorizes the commands into eleven major groups: 

File File input output and printing commands. 

Edit Text file editing commands. 

View CASLide commands to change display look and feel. 

Image Commands for editing bitmaps and icons. 

Layout Used to align, space and size controls on forms. 

Debug Execution control while debugging. 

Project Used to change the project settings. 

Build Compile programs and prepares for download. 

Execute Run the CASL program under Windows 

Tools Modify CASLide internal settings 

Window Viewable window manipulation. 

Help Access Help screens. 

The File Menu 
Most CASLide operations pertaining to the management of source and project files are 
performed from the “File” menu.  The menu contains the file-oriented commands that 
can be performed by CASLide, as well a list of the most recently opened project and 
source files.  Selecting any file from the list (or using its associated digit key) will cause 
it to be immediately re-opened for editing. 

The file menu commands are: 

New Open a new source file for editing. 

Open Open an existing source file for editing. 
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Open Form Source Open a form file as a read-only source file. 

Close Close the source file being edited. 

Save Save source file in the currently focused window. 

Save As Save the source file with a new name. 

Save All Save all of the source files that are opened. 

Recent Project Displays a list of the most recently opened projects. 

New Project Create a new project. 

Open Project Open an existing project 

Close Project Close the open project 

Print Print source file in the currently focused window. 

Print Preview View source file before printing. 

Page Setup Modify printing options (margins, etc.) 

Print Setup Modify Windows printing environment. 

Exit Terminate CASLide execution. 

New (key sequence Ctrl + N) 

A dialog is shown to allow selecting the type of file to create. The five choices are: 

 CASL source - A text file with the extension CSL 

 CASL package - A text file with the extension CPK 

 CASL form  - A form file with the extension CFF 

 CASL ICON - An image file with the extension CIC 

 CASL bitmap - A bitmap file with the extension CBM 

C file   - A CASLpro C file with the extension C 
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H file                    - A CASLpro C header with the extension H 

An empty file is then created. The newly opened window becomes active, and all 
subsequent commands will be applied to the file that it contains. 

The file in the newly opened window is automatically assigned the temporary name 
“CASLide”, with the appropriate suffix (CSL, CPK, CFF, CIC, CBM, C or H).  Before 
the file is closed or compiled, it must be assigned a permanent name (see “Save As”). 

CASL bitmaps are compatible with Windows BMP files as long as they are no larger 
than 1000 pixels. 

Bitmap and Icon file names must be valid CASL variable names. Names must begin 
with a letter and may continue with any desired combination of letters and numbers.  
Remember that CASL considers the underscore to be a letter. Names can be any 
length desired, but only the first 79 characters are significant. Names are not case 
sensitive thus; ACASLName is, to the compiler, the same as acaslname. 

NOTE: Bitmap and Icon file names cannot have the same name as a CASL statement 
such as file. 

NOTE: Do not name your CPK files startup or shutdown because these names are 
reserved for the compiler. 

CASLpro C files will have these include files automatically add when the file is created: 

#include <CASL_support.h> 

#include <CASL_prototypes.h> 

Open (key sequence Ctrl + O) 

The purpose of this command is to open a new editing window containing an existing 
CASL source or image file.  CASLide first shows a file selector box, which will allow 
the name of an existing file to be entered or selected from the displayed file list or 
directories.  Once a file name is provided, the new window will be opened and become 
active, and all subsequent commands will be applied to the file that it contains. 
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Open Form Source 

A form file normally is displayed in its graphical representation. This menu command 
will open the form file as a read-only text file. Normally this is not needed, but is 
supplied to allow debugging in case of an unexpected compiler error. 

Close 

The currently active editing window is closed by this command.  If the file within the 
window has been changed, CASLide displays a dialog box requesting whether or not 
the associated source file should be saved to disk. If “yes” is selected, the file is saved 
to disk.  If the file does not yet have a permanent name, the “Save As” file selector box 
(see below) is used to assign the permanent name to the file.  This command only 
appears in the menu if there is an open source file window on the display. 

If the file has not been changed, the window is simply closed.  The processing of this 
command is also triggered if the “Close” action is taken on the open editing window. 

Save (key sequence Ctrl + S) 

The CASL source, form, or image file in the currently active window is saved to disk by 
this command.  If the file does not yet have a permanent name, the “Save As” file 
selector box (see below) is used to assign the permanent name to the file.  This 
command only appears in the menu if there is an open file window on the display. 

Save As 

When requested this command will cause CASLide to show a file selector box, which 
will allow file name to be entered or selected from the displayed file list or directories.  
This command only appears in the menu if there is an open file window on the display.  
The “Save As” dialog box also appears if a file window that does not have a permanent 
name is closed or has the “Save” command applied to it. 
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Save All 

This will save the changes of all the opened files and the project file. This command 
only appears in the menu if there are one or more open file windows on the display.  
The “Save As” dialog box also appears if a file window that does not have a permanent 
name is closed or has the “Save” command applied to it. 

Recent Projects 

A list of most recent projects are shown as a pick list, allowing the developer faster 
access to current development projects. 

New Project 

A new project is defined by selecting this menu item. A file dialog box will be 
presented, to choose a project name. All source, form, and image files that make up 
the application are tied to this file. The application is scanned looking for an include file 
dependencies, and the file names stored in the Include folder in the project tree.  The 
project can be manually rescanned at any time by selecting the Project, Update 
Includes menu item. 

There is an option in Tools->IDE Settings that allows specifying a project name that is 
different from the application source file name. When this option is not selected, a 
dialog box is display, when the project is created, that prompts for the source file name 
after a project name has been assigned. 

A CASL source file (CSL) and form file (CFF) are created and added to the project. 

Open Project 

An existing project can be opened, and its settings restored, using this menu item. A 
file dialog box of existing projects is displayed, allowing the developer to pick one buy 
selecting one and pressing the Ok button, or by double clicking the desired project. 
The toolbars, views, opened files, and project settings are restored, thus allowing the 
application author to resume the project development where they left off. 
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Close Project 

This will close the project that is currently opened. 

Print  (key sequence Ctrl + P) 

The CASL source file in the currently active window will be output to the printer by this 
command.  This command only appears in the menu if there is an open source file 
window on the display. 

CASLide image and form files can not be printed. 

Print Preview 

This command allows the printed output to be viewed on the display before being sent 
to the printer.  The preview window allows the viewed text to be zoomed, shown in 
single or double page mode, stepped forward or backward page by page, and printed.  
The preview window can be closed with the “Close” button or by pressing the “escape” 
key. This command only appears in the menu if there is an open source file window on 
the display. 

CASLide image and form files can not be previewed. 

Page Setup 

The dialog box displayed when this command is requested can change the 
characteristics of the page produced by the print command.  The contents of the 
header and footer can be modified, as well as the top, bottom, left and right margins. 

The following options allow you to define the header and footer contents, and the 
dimensions of the page margins. 

Header 

Enter the text you wish to be printed on the top of each page. You make also include 
the following symbols. 

&f File name 

&p  Page number 
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%a Abbreviated weekday name 

%A Full weekday name 

%b Abbreviated month name 

%B Full month name 

%c Date and time representation appropriate for locale 

%d Day of month as decimal number (01 – 31) 

%H Hour in 24-hour format (00 – 23) 

%I  Hour in 12-hour format (01 – 12) 

%j  Day of year as decimal number (001 – 366) 

%m Month as decimal number (01 – 12) 

%M Minute as decimal number (00 – 59) 

%p Current locale’s A.M./P.M. indicator for 12-hour clock 

%S Second as decimal number (00 – 59) 

%U Week of year as decimal number, with Sunday as first day of week (00 – 51) 

%w Weekday as decimal number (0 – 6; Sunday is 0) 

%W Week of year as decimal number, with Monday as first day of week (00 – 51) 

%x Date representation for current locale 

%X Time representation for current locale 

%y Year without century, as decimal number (00 – 99) 

%Y Year with century, as decimal number 

%z, %Z   Time-zone name or abbreviation; no characters if time zone is unknown 

%% Percent sign 
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Footer 

Enter the text you wish to be printed at the bottom of each page. The same symbols 
used in the header can also be used in the footer. 

File Time 

Use the time the file was last modified. 

System Time 

Use the time when the document was printed. 

Margins 

This allows setting the amount of white space that surrounds the printed document. 

Print Setup 

This command triggers CASLide to produce the Windows standard Printer control 
dialog box, so that the printer itself can be changed, as well as printer control 
parameters.  Parameters such as portrait/landscape paper size and other printer 
specific parameters can be modified by this dialog. 

Exit (key sequence ‘x’) 

CASLide will terminate execution when this command is requested.  Each open CASL 
file that has been changed will trigger the dialog interaction described in the “Close” 
command above. 

The Edit Menu 
Each open window containing a CASL source, form, or image file can have the 
commands from the edit menu applied to it. Different edit options are enabled 
depending if the active view is for a source, form, or image file. 
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The source edit commands allow manipulations on larger blocks of text than can be 
performed with simple keyboard entry and deletion. Drag and drop text editing is 
supported. A block of text can be highlighted and moved by placing the cursor on the 
selected text, holding the left mouse button down, and then dragging the text to its new 
location. This can even be done between views and external documents. 

The source file edit menu is: 

Undo Reverse the last edits made. 

Redo Redo the previously undone edit. 

Cut Move marked text from file to Windows clipboard. 

Copy Copy marked text from file to Windows clipboard. 

Paste Place Windows clipboard contents into the file. 

Find Find matching text strings in file. 

Replace Replace matching text strings in file. 

Find in Files Find all occurrences of string in the project files. 

Find Function Find a function definition that matches the selected text. 

Find All Functions Find all functions and list them in the output window. 

List Object Properties Display a popup with the valid object properties. 

Toggle Bookmark Set and clear a bookmark on the current line 

Next Bookmark Jump to the next bookmark 

Previous Bookmark Jump to the previous bookmark 

Clear All Bookmarks Clear all bookmarks in the active window 

Insert Color Value Popup a color list and insert the select color's RGB value 

The image file edit menu is: 

Undo Reverse the last edit made. 
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Clear Clear the image work area. 

Restore Restore the last saved image. 

Paste Place clipboard contents into the selected region. 

Copy Copy selected region to the clipboard. 

Find in Files Find all occurrences of string in the project files. 

Find All Functions Find all functions and list them in the output window. 

The form file edit menu is: 

Undo Reverse the last edits made. 

Copy Copy selected display object from file to Windows clipboard. 

Paste Place Windows clipboard contents into the file. 

Delete Delete the selected display object. 

Select All Select all display objects on the form. 

Go to Invoker Position the cursor to an object's invoker function. 

Find in Files Find all occurrences of string in the project files. 

Find All Functions Find all functions and list them in the output window. 

Undo - (key sequence Ctrl + Z) 

This command allows the last file modification to be reversed.  This is useful when a 
typing error causes the mistaken deletion of text or display object. 

Only the last modification can be undone for image files. 

Redo - (key sequence Ctrl + Shift + Z) 

This command redoes the last undone action. This is useful when you want to reverse 
and undo.  Note that only the last undo operation can be undone. 
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This command is only available for text files and not available for image or form files. 

Cut - (key sequence Ctrl + X) 

The highlighted text in the edit window is removed from the window and copied to the 
Windows clipboard.  This command is useful for moving blocks of CASL source code 
from one file to another.  It can also be used as a “delete” operation, to erase the 
highlighted block of text, although the highlighted block could also be removed by 
simply hitting the “delete” key.  This command is only available in the Edit menu if 
there is highlighted text in the window. 

This command is only available for text files and not available for image or form files. 

Copy - (key sequence Ctrl + C) 

For source and package files, the highlighted text in the edit window is copied from the 
to the Windows clipboard by this command.  This command is useful for copying 
blocks of CASL source code from one file to another.  Since the standard Windows 
clipboard is the target of this command, the highlighted CASL source code can be 
copied into virtually any other Windows application.  This command is only available in 
the Edit menu if there is highlighted text in the window. 

For form files, the selected display object, or group of objects is copied to the 
clipboard. A group of display objects can be selected by clicking and holding the left 
mouse button and then dragging the selection box to encompass the desired controls. 
Display objects can be copied between forms, however selector list arrays on copy the 
array reference and not the contents. 

For image files, the selected region is copied to the clipboard. The region is selected 
using the selection toolbox tool (rectangle with the dotted boarder). 
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Paste - (key sequence Ctrl + V) 

For source and package files, the contents of the Windows clipboard is placed into the 
file contained in the currently active window, at the current cursor position within the 
window. This command is also useful for moving blocks of CASL source code from 
one file to another.  Any text that was moved to the Windows clipboard by any 
Windows application can be moved into the CASL source file by this command.  This 
command is only available in the Edit menu if there is currently data in the Windows 
clipboard. 

For form files, the display objects are copied to the destination with the same position 
and size as the source objects. New names are assigned to each of the pasted 
objects regardless if the destination form is the same as the source form, or some 
other form. 

For image files, the contents of the clipboard are copied into the newly selected region. 
If the destination region is a different size then the source region, a dialog box is 
presented asking if the pasted image should be resized to fit the new area, or should it 
be clipped. 

Find - (key sequence Ctrl + F) 

When requested, this command causes CASLide to display a dialog box that allows 
the entry of a string to be found in the source file in the currently active window.  The 
search begins at the current cursor position in the window.  When found, the matched 
text is highlighted in the window.  The dialog box also provides search options that 
allow forward and reverse searching through the file, as well as the ability search in a 
case-sensitive mode.  The “Find Next” button in the dialog box move to the next 
matching string (forward or backwards) in the file. 

This command is not available for form or image files. 

If Regular Expression is checked, the following characters have special meaning: 

\ Marks the next character as a literal and allows using the special 
characters as text characters. For example, "\*" matches the character "*" 
where as without the "\" the character "*" would represent matching the 
preceding character zero or more times.  
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^ Matches the beginning of input. For example, "^Start" would match "Start" 
only if it started at the beginning of the line. 

$ Matches the end of input. For example, "Start$" would match "Start" only if 
it ended the line. 

* Matches the preceding character zero or more times. For example, "zo*" 
matches either "z" or "zoo". 

+ Matches the preceding character one or more times. For example, "zo+" 
matches "zoo" but not "z".  

? Matches the preceding character zero or one time. For example, "a?ve?" 
matches the "ve" in "never".  

. Matches any single character except a newline character.  

(pattern) Used to group expressions. For example, "(w|s)ay" would match "way" or 
"say" but "w|say" would match any "w" or "say". 

x|y Matches either x or y. For example, "z|food" matches "z" or "food". 
"(z|f)ood" matches "zoo" or "food".  

[xyz] A character set. Matches any one of the enclosed characters. For 
example, "[abc]" matches the "a" in "plain".  

[^xyz] A negative character set. Matches any character not enclosed. For 
example, "[^abc]" matches the "p" in "plain".  

[a-z] A range of characters. Matches any character in the specified range. For 
example, "[a-z]" matches any lowercase alphabetic character in the range 
"a" through "z".  

[^m-z] A negative range characters. Matches any character not in the specified 
range. For example, "[m-z]" matches any character not in the range "m" 
through "z".  

Find in Files (key sequence Ctrl + Shift + F) 

This will search for all occurrences of a string in the project CSL and CPK files. 
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If you highlight a string then that will be the default search string. The CSL and CPK 
files are searched and all lines found will be displayed in one of the two new windows 
on the output bar. The Find in Files 1 window is the default unless the pane 2 
checkbox is selected. 

You can then double click a line in the output window to position to the file and line. 

See Find for a description of Regular Expressions. 

Find Function (key sequence Shift + F2) 

This will find the function definition that matches the function name specified by the 
currently selected text. This is also available by clicking the right mouse key and 
picking it from the context menu. 

If it finds a function’s forward reference first, then just reselect the function name and 
do the find again. You can reselect the function name by double clicking on the 
function name text. 

The function name text must be selected for this feature to be enabled.  

Find All Functions 

This will make a list of all of the functions and display the list in the output window. 
Double clicking a line will position the cursor to the function and open the source file if 
it was not already open. 

Replace - (key sequence Ctrl + H) 

The ability to do large-scale text substitutions is provided by this command.  The 
capabilities of the “Find” command are extended with the option of allowing a 
replacement string to be specified for the matched string.  The dialog box displayed by 
the “Replace” command also contains a button “Replace All” which will perform an 
unconditional substitution of the matched string with the replacement string throughout 
the file. 

This command is not available for form or image files. 
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Restore 

This will revert to the last saved image. This menu item is only available for image 
files. 

Clear- (key sequence Del) 

Use this menu item to erase the entire image work area. This is only available for 
image files. 

Delete- (key sequence Del) 

This menu command will erase the selected display objects. This is only available for 
form files. 

Select All - (key sequence Ctrl + A) 

Use this menu item to select all of the display objects on the current form. This is only 
available for form files. 

Go to Invoker 

This will position the cursor to the selected control object's invoker function. This menu 
option is also available on the context menu. Pressing the right mouse button after 
selecting a control will display the Form Builder context menu. 

List Object Properties - (key sequence F2) 

This will display a popup of valid CASL object types. You can then select an object 
type and double click or press the enter key and another popup is display with the 
object properties for the selected object type. Selecting the property will automatically 
insert the property name after the cursor. 

You can exit either popups by pressing the escape key. 

A new checkbox was added under Tools->IDE Settings called "Allow object property 
detection". If this is checked then the List Object Properties popup will be shown if a 
period is typed after a valid CASL name. 
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Toggle Bookmark 

Bookmarks can be set for source (CSL and C) and include (CPK and H) files allowing 
you to bookmark a place in the file being edited and then returning to the bookmark. 
You can also use the "Mark All" button on the find dialog to set bookmarks on all lines 
that match the text being searched. Once one or more bookmarks are set you can 
position to them using the Edit menu, Edit toolbar or Edit context menu bookmark next 
and previous commands. Bookmarks are local to a single document and the next, 
previous and clear commands do not span documents. 

Next Bookmark 

This will jump to the next bookmark in the active window. 

Previous Bookmark 

This will jump to the previous bookmark in the active window. 

Clear All Bookmarks 

This will clear all bookmarks in the active window. 

Insert Color Value - (key sequence Ctrl + F2) 

This will display a color selection popup and will insert the selected color's RGB value 
at the current cursor position. For example if you were adding the following line: 

my_button.background = ; 

You would position the cursor after the equals sign and press Ctrl+F2. Select the color 
yellow and the line would now look like this: 

my_button.background = 65535; 
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The View Menu 
The display characteristics of CASLide itself can be modified by the commands in the 
View menu.  The various user interface elements (coloring, font, status bar, build view, 
etc.) can be enabled, disabled, or adjusted by the commands in this menu. 

The source file “View” menu commands are: 

Status Bar Toggles the status bar at the bottom of CASLide. 

Workbook Mode Enables / Disables the tabbed view of the edit windows. 

Watch Bar Show / Hides the global and local display. 

Project Bar Show / Hides the tree view of the project. 

Build Window Show / Hides the build window. 

Debug Window Show / Hides the debugger window. 

The image file “View” menu commands are: 

Status Bar Toggles the status bar at the bottom of CASLide. 

Workbook Mode Enables / Disables the tabbed view of the edit windows. 

Project Bar Show / Hides the tree view of the project. 

Build Window Show / Hides the build window. 

Debug Window Show / Hides the debugger window. 

Options Allows enabling the grid and changing brush size settings. 

The form file “View” menu commands are: 

Status Bar Toggles the status bar at the bottom of CASLide. 

Workbook Mode Enables / Disables the tabbed view of the edit windows. 

Project Bar Show / Hides the tree view of the project. 

Build Window Show / Hides the build window. 
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Debug Window Show / Hides the debugger window. 

All of the views have these menu commands: 

File Toolbar Show / Hides the file toolbar 

Execution Toolbar Show / Hides the execution toolbar 

Debugger Toolbar Show / Hides the debugger toolbar 

Form Layout Toolbar Show / Hides the form layout toolbar 

Form Controls Toolbar Show / Hides the form controls toolbar 

Image Toolbar Show / Hides the image toolbar 

Status Bar 

The status message bar typically displayed at the bottom of the CASLide window is 
enabled or disabled by this command.  When the status bar is enabled, the associated 
text in the “View” menu is checked to indicate so. 

The status bar contains several panes that contain information about the state of the 
current form. 

The first pane will contain: 

The current line and column for source files. 

The size and position of the pen for image files. 

The size and position of the selected display object for form files. 

The second pane shows the state of the Caps Lock key. It is on if CAP is shown. 

The third pane shows the state of the Num Lock key. It is on if NUM is shown. 

The forth pane shows the Insert/Overwrite state. Overwrite mode is on when OVR is 
shown. This is only used for source files. 

The fifth pane displays the current time. 
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Workbook Mode 

A tabbed folder, where each file has a tab with its name on it, can represent the 
multiple views of the open files. A file's tab can be clicked to bring that file into focus. 

Watch Bar 

The watch bar is used to display the global and local variables during debug mode. 
The watch bar can be hidden and made visible using this menu item. This menu item 
is only available during debugging. 

Project Bar 

The project bar shows all of the files associated with a project as a tree view. Any file 
represented by a folder Icon on the tree can be double clicked to open the folder. The 
project bar can be hidden and made visible using this menu item. 

Double clicking on items in the project tree will perform various tasks: 

Source, form, and image files can be added to the project by double clicking the 
top Icon (project Icon) on the tree. 

The source file can be opened by double clicking the second Icon (source Icon) 
from the top of the project tree. 

A include file (package file) can be opened by double clicking one of the file 
Icon’s in the Includes folder. 

A form file can be opened by double clicking one of the file Icon’s in the Forms 
folder. 

An image or bitmap file can be opened by double clicking one of the file Icon’s in 
the Images folder. 

Build Window 

The build window is used to display the results of the compile and creation of the final 
p-code/executable. This window is automatically displayed when a build operation is 
performed. 



                                                                                                                      CASLide 
Version 4.3 

 29

Debug Window 

The debug window is used to display user selected and function local variables while 
in debug mode. This window is automatically displayed when the debugger is started. 

The ability to show the debug window while not debugging is helpful when one or more 
variables where defined to be displayed and the variable context is not valid at startup. 
Since the CASLwin runtime is responsible for fetching the variable value, it will error 
and quit if it parses an invalid watched variable. The invalid watch variables can be 
removed before debugging by displaying the debugger window and deleting the 
variable that is causing the error. 

Options 

For image files the are two sub-menus: 

Grid - This will toggle the pixel grid. When displayed, it allows the designer to see the 
pixel boundaries. 

Brush Size - This allows changing the size of the paintbrush. The paintbrush can be 
changed from a 2 by 2 pixel to a 5 by 5 pixel brush. 

Tool Bars 

The view toolbar items show and hide the various CASL tool bars. 

File Toolbar 
Show / Hides the file toolbar 

Execution Toolbar 
Show / Hides the execution toolbar 

Debugger Toolbar 
Show / Hides the debugger toolbar 
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Form Layout Toolbar 
Show / Hides the form layout toolbar 

Form Controls Toolbar 
Show / Hides the form controls toolbar 

Image Toolbar 
Show / Hides the image toolbar 

The Image Menu 
The CASL Image Editor is used to create PRC Icon and button/label bitmap files. 

Each CASL project can optionally have an Icon associated with it. If the Icon is not 
specified (see Project Settings menu), then the default CASL Icon will appear on the 
PalmPilot desktop. 

NOTE: The icon size has changed in CASL42. The previous icon size was 32x22 (see 
High Resolution PalmOS Graphics). The new sizes are: 

Screen resolution desktop icon list icon 

low-res 22x22 15x9 

hi-res 44x44 30x18 

 

There can be any number of bitmap files defined in a project. The size of the bitmap 
file can be changed using the Image menu Bitmap Properties dialog. NOTE: The 
bitmap will be cleared if the size is changed. 

Pencil   Draw one pixel at a time 

Brush    Draw wider lines 

Line    Draw a straight line 

Hollow Rectangle  Draw a rectangle or square with a border 
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Solid Rectangle  Draw a filled rectangle 

Hollow Ellipse  Draw an ellipse or circle that has a border 

Solid Ellipse  Draw a filled ellipse 

Fill    Flood fill an area bounded by a shape 

Color Dropper  Pick a color from an existing image 

Select   Used to mark a region to be copied or pasted 

Bitmap Properties Change the width and height of a bitmap file 

New Bitmap Type Add a new bitmap to a bitmap family 

Delete Bitmap Type Remove a bitmap from a bitmap family 

Import Image Convert a BMP file to a CASL image file 

Pencil 

The Pencil is used to draw one pixel at a time. You can drag the pencil to draw 
shapes. 

Brush 

The Brush is like the pencil but used to draw wider shapes and or lines. The width of 
the brush is defined by the View->Options->Brush Size menu. 

Line 

The Line selection allows drawing straight lines. After selecting this tool, press the left 
mouse button at the location where you wish the line to start, and while depressing the 
button drag to the desired end point. 
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Hollow Rectangle 

The Hollow Rectangle is used to draw a rectangle or square that has a border one 
pixel wide. Click the left mouse button where you wish the top left corner to start and 
while hold the button, drag to where you wish the bottom right corner. 

Solid Rectangle 

The Solid Rectangle is the same as the Hollow Rectangle tool, but will draw a 
rectangle that is filled. 

Hollow Ellipse 

The Hollow Ellipse will draw an ellipse or circle that has a border one pixel wide. Click 
the left mouse button where you wish the bounding rectangle to start (the bounding 
rectangle will not show, but the circle will be contained within it), and while depressing 
the button, drag to the desired size and shape. 

Solid Ellipse 

The Solid Ellipse is the same as the Hollow Ellipse, but is used to draw an ellipse 
that is filled in. 

Fill 

The Fill is used to flood fill an area bounded by a shape. You can use the left or right 
mouse button to fill with the color selected for the mouse button. 

Color Dropper 

Select the Color Dropper and then click the left or right mouse button over a bitmap 
pixel to select the pixel's color. 
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Select 

The Select tool is used to mark a region to be copied or pasted into. To copy a section 
of an image, select this tool a click the left mouse button at the top left corner of the 
region to be selected. While holding the button down, drag the mouse to the bottom 
right corner of the area. Release the left mouse button and do the copy menu 
command (or Ctrl-C). Select the destination region in the same manner, and do the 
paste menu command (or Ctrl-V). A dialog is presented if the source and destination 
regions were not the same size. The dialog allows selecting the option to resizing or 
clips the pasted image to fit the destination region. 

Bitmap Properties 

This is used to change the width and height of a bitmap file. The valid range is from 1 
to 1000 CASL units. 

Bitmaps are scaled to fit the destination screen size. If you create a large bitmap and it 
is scaled down, it will be distorted. You should change the CASL units from the Project 
Settings dialog to match the destination screen size to avoid this. 

The width and height can only be changed for bitmap files. 

NOTE: The bitmap will be cleared if the size is changed. 

New Bitmap Type 

A bitmap can consist of a color and monochrome bitmap image. This is called a 
bitmap family. If you want your application to run on color and monochrome devices 
then you will need to create a bitmap family consisting of a color image and a 
monochrome image. The device will decide which to display. 

To create a bitmap family first create a color or monochrome image then select New 
Bitmap Type from the Image menu. This will add a color or monochrome image to the 
existing image that has the same dimensions as the existing image. If you had color it 
will add monochrome and visa-versa. You can select the color or monochrome family 
member using the combobox that is on the image toolbar. 
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Delete Bitmap Type 

If you wish to delete one of the images from a bitmap family then select the one you 
wish to delete in the combobox on the image toolbar and pick Delete Bitmap Type 
from the Image menu. 

Import Image 

An import function is available on the Image menu. This will allow adding a color or 
monochrome BMP image to a CASL image file. There can only be one color and one 
monochrome image in a CASL image file. 

A bitmap family can not be read by CASL versions earlier than 3.2 and can not be read 
by external image editing tools such as Window's Paint utility. 

The Project Menu 
A project consists of all of the files that are used to create an application. The main 
source file, include files (packages), image files, and form files are represented on the 
project tree. From this menu item, files can be added, removed from the project, 
project variables defined, and the source file rescanned to determine which include 
files are present. 

Add Files Add a new form or Icon to the project 

Add MenuBar Add or edit a menu bar. 

Remove Project Item Remove the selected form or Icon from the project 

Project Settings Define the form screen size and default font 

Project Variables Define global variables set by the project 

Application Settings Set desktop name, creator ID and more 

Application Install Settings Define the application installer options. 

Update Includes Rescan the include files 

Check for Duplicates Check for duplicate object names 
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Compatibility Mode Select version 2.0 compatibility 

Add Files 

This is where form and image files can be added to the project. Only one image file 
can be added which contains the Icon shown on the PalmPilot desktop. See the File 
menu command to read about how to create a new ICON image. 

Add MenuBar 

The Add MenuBar will display a dialog that is used to add and modify menu bar 
definitions. Selecting the menu bar in the project tree and then selecting Remove 
Project Item from the Project menu can delete a menu bar. A menu bar cannot be 
deleted or renamed if a frame uses it. 

Items can be deleted by selecting the item in the menu bar tree and then press the 
delete key. Dragging and dropping the item to a new location can move items. 

The top folders represent the menu bar objects, the next level is the menu top object 
and the last level is the menu item object. 

Selecting a level and pressing the “New” button will create a peer object (i.e. select a 
menu top and the “New” button will create a new menu top under the same menu bar). 

The menu bar is displayed in the project tree and can be opened by double clicking a 
MenuBar item. 

The menu bar definitions are stored in a file that is named the same as the project with 
the suffix "_menubar.ini" and is in the project directory folder. 

Remove Project Item 

This will remove the file selected in the project tree from the project. Only image, menu 
bar and form files can be removed this way. 

Project Settings 

Project Settings 
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This allows setting the default font used by the Form Builder, CASLwin and CASLppc 
runtimes. This font will be used for the StdFont, BoldFont, and LargeFont settings. The 
font style and size are not used. If you wish to change these then you will need to set 
the font on each display object using its font modifier settings. 

If the 'Use CASL fonts' checkbox is checked, the CASL font files will be used for 
StdFont, BoldFont, LargeFont, etc. These fonts match the PalmPilot fonts and include 
the symbol fonts. The CASL Fonts must be installed in the Windows Fonts directory. 
The CASL installer does this. 

The form height and width sizes for the form design and runtime display can also be 
configured here. This will set the form size used by the CASLwin and CASLppc 
runtimes. It has no affect on the PalmPilot runtime. 

In prior releases, the CASL units were from 0-999. This can now be changed using 
CASL Display Size. The allowed range is 100-1000. If you set this to 160x160, then 
each CASL unit will be one PalmPilot pixel. Likewise one bitmap pixel will be one 
PalmPilot pixel so this would eliminate any distortion that would have been caused by 
stretch in the bit map to fit dimensions other than 160x160 (320x320 seems to be ok 
also). This should also help with making CASLide's form builder match the PalmPilot 
screen. 

Form controls are adjusted when the CASL units are changed. You will need to still 
need to change your bitmaps and make any code changes if you have position and 
size information in your code. 

The Project Settings dialog now has two color wells for text and background color and 
a checkbox to use only system colors. These are used as default settings for newly 
created objects (i.e. not one loaded from an existing form file). 

The object property page also has these but for the specific object. This is where you 
can customize the text and background color of a CASL display object. Leaving the 
"Use System Colors" checkbox set will make it look like CASL 3.1 and earlier. Please 
read Display Object Color for more details. 

The ‘Allow 1-bit color control’ checkbox will enable black and white coloring for 1-bit 
color depth PalmOS 3.5 and above devices. Windows OS devices ignore this setting. 
If this is set, then care must be taken to map colors such that the foreground and 
background colors do not both become white or black on a 1-bit device. For example, 
the color blue will show as black and the color green will show as white. 
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These settings are stored with the project. If there is no project open then any changes 
you make to these and the non-project related items (toolbars, CASLide position, etc.) 
would be save as the defaults. When a new project is created, these defaults will be 
used. To change the defaults, close the current project, make the changes and then 
exit the IDE. 

Project Variables 

Project Variables 

Selecting this menu item will display an editable list dialog where numeric and string 
variables can be defined for the project. The syntax used is the same as used in the 
source file but without the trailing semi-colon. 

Numeric Fred = 0 
Count = 10 
Name = “Ethel” 
String MSG = “Warning! Warning! Dr. Smith” 
Flags[5] = $0 

The variables are compiled into the project as if they were part of the source. These 
could be used in conjunction with the COMPILE_IF directive to use the same source 
modules in different projects. 

Note: You will get “Duplicate variable name” compiler error message if you have 
project variables with the same name as variables declared in the source. 

If you enter a variable with improper syntax, the compiler will display an error message 
showing line zero has a problem. For example the following compiler error message 
was produced with the project variable, MSG = x: 

File (null), Line   0: x is unknown function 

Application Settings 

Application Settings 

This allows setting the creator ID, desktop name, splash screen and other application 
settings depending on the build type, PalmOS or PocketPC (not available for Windows 
builds). 
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Creator ID 
The creator ID is used to associate an application and its databases. Each application 
must have a unique creator ID. See Make PRC for more details about how to get a 
creator ID for your application. The creator id is an alphanumeric string that is from 1 
to 4 characters in length. 

You will need to install a CASL ActiveSync Provider / HotSync registry entry for the 
new creator ID. Please read installing the CASL Conduit for more details. 

Separate copies of the creator id are kept for PalmOS and PocketPC builds. If you 
have more than one PocketPC application that needs to share dbfiles, then set the 
creator id to the same value for all of the PocketPC applications. You should use the 
creator id of the application that uses the installer so the files are removed when the 
application is uninstalled. This was done so CASLrt applications work properly in 
PocketPC. 

Database creator ID checkbox (Palm only) 
If the Database creator ID checkbox is checked then the databases created by the 
application will use the application creator ID and not the CASL creator ID. When the 
application is deleted from the PalmPilot, the database(s) will also be deleted. This 
option is only available when doing Palm Professional Edition C Builds. 

This setting is always enabled for PocketPC builds and therefore is not shown and is 
not changeable. 

Desktop Name 
This is what will be displayed on the device’s desktop. Each application must have a 
unique desktop name. 

Splash Screen 
The splash screen is a bitmap image that is shown at startup. The splash screen is 
displayed when the application starts and is removed when the first form is ready for 
display. This option is only available when doing CASLpro or PocketPC builds. 

For PocketPC, the top left pixel color is used to fill in the border area not covered by 
the bitmap image. 
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Enable SIP Resize (PocketPC only) 
When this is selected the PPC screen view will resize to show the CASL program's full 
screen view when the user brings up the Soft Input Panel (SIP) keyboard.  If you don't 
select, the SIP will display on top of the lower portion of the CASL program's full 
screen view.  In either case when the SIP is removed from view, the CASL program's 
screen view will return to full screen view. 

PRC Type (Palm only) 
The PRC Type can be set to Application or Library. A library functions the same as an 
application but is not shown on the PDA’s desktop. For example, you could have an 
application that has three executable files and only one should be executed from the 
desktop. The main file would have PRC type set to Application and the other two 
would have PRC type set to Library. Library files must also have a unique creator ID. 
HotSync does not support database created with the library creator ID. 

Note: You must delete the library from the PDA before changing its desktop name 
otherwise it will keep the old name. 

PRC Version (Palm only) 
The PRC Version edit box allows specifying a version for the application. This can be 
any text string 15 characters or less.  The version string will be copied to the PRC 
version resource and can be viewed on the PalmPilot Info screen. The "v." is added to 
the front of the version string by Palm OS. This option is only available when doing 
Professional Edition C Builds. 

Beam Option (Palm only) 
The application cannot be beamed if the “Non-beamable application” checkbox is 
marked. This applies to PRC Types Application and Library. This option is only 
available when doing Professional Edition C Builds. 

Note: The application that does the beaming needs to look at this bit and disable the 
beaming if set. It is not done automatically by PalmOS unless you use the beaming 
capability that is built into the PalmOS Desktop. 
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Application Install Settings 

CASLinstall is used to create an install package that will install your PDA application, 
data files and conduit on your user's machine. It can be access from two CASLide 
menus: Project and Build menus. 

The Project->Application Install Settings menu will open the CASLinstall design dialog 
and position to the first tab. 

The Build->Build Application Installer menu will do the same but position to the build 
tab. 

CASLinstall supports only Palm and PocketPC builds, not CASL applications built to 
run on Windows. 

Update Includes 

The main application file is scanned looking for include files when the project is 
created, opened or this menu item selected.  Each include file is also scanned looking 
for other include files. All of the include files found are then placed in the include folder 
in the project tree. 

This command is not available for form or image files. 

Check for Duplicates 

This will check for duplicate form objects and selector list variable names. 

The Build Menu 
The act of preparing a CASL program for execution is accomplished by the commands 
in the Build menu.  These commands allow the CASL source file in the currently active 
project to be compiled to run on the PalmOS, PocketPC or on the Windows. The 
active configuration combo box on the build toolbar determines the type of build. A 
subdirectory named the same as the configuration is created under the application 
directory during the build process. All of the output files for the build configuration is 
placed in this subdirectory. 



                                                                                                                      CASLide 
Version 4.3 

 41

Different menu options are enabled or disabled depending on the build type. For 
example, if "Windows Release" or "Windows Debug" is selected, then the  "Make 
PRC", "Install PRC", and "Install CSM" menu items are disabled (grayed out). If 
"Windows Release" is selected, then the debug execute menu item is disabled. 

The act of compiling a CASL program will check for syntax errors, and (if there are no 
errors) translate the CASL source code into CASL p-code.  For the PalmPilot, the 
compiler emits the p-code in a file with the same name as the project file, but with an 
extension of .CSM. For the PocketPC, the compiler emits the p-code in a file with the 
same name as the project file, but with an extension of .CCE.  When compiling for the 
Windows environment, the extension is .CSP. 

Before actually doing the compile, CASLide checks if the files need to be saved and if 
so saves the source file to be compiled to the disk.  There is a CASLide Settings 
option under the Tools menu item that enables and disables a prompt that confirms 
that the files should be saved. If the source file does not yet have a permanent name, 
CASLide will display a dialog box indicating that it must be given one before it can be 
compiled. 

During the compile process, if errors are encountered they are displayed in a sub-
window at the bottom of the main CASL window.  Double clicking on an error message 
in the sub-window will mark and bring into view, the incorrect line in the CASL source 
file being compiled, so that errors can be found and corrected easily. The contents of 
the build window can also be copied and pasted to a text document. Selecting the text 
to be copied accesses the copy/paste options, clicking the right mouse button, and 
then selecting copy. 

After a p-code file has been produced for execution on the PalmPilot, it can be 
immediately installed for download, or converted to a PalmPilot Program Resource 
(PRC) file.  A CSM p-code file can only be invoked on the PalmPilot from the startup 
selection list of the CASL runtime interpreter (CASLrt).  A PRC file will appear on the 
PalmPilot desktop so that it can be invoked directly with a single pen tap. 

The “Build” menu commands are: 

Compile Compile based on the active build configuration. 

C Build Compiler will emit C code 

Build Application Installer Create the application install package. 
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Make PRC Construct PRC file from CASL p-code file. 

Install PRC Install PRC files into PalmPilot download directory. 

Install CSM Install p-code files into PalmPilot download directory. 

PocketPC Install Copy the CCE file to the PocketPC install directory. 

Compile - (key sequence F7) 

This command invokes the CASL compiler to translate the source file in the currently 
opened project to p-code to be executed on the PocketPC, Windows or PalmOS 
depending on the build configuration. The build configuration is selected using the 
combo box on the build toolbar. 

The p-code generated for the Windows PC will be named with a “CSP” suffix. 

The p-code generated for the PalmPilot will be named with a “CSM” suffix.  Any errors 
will be displayed in the compiler’s error log sub-window. 

If the p-code application compiles with no errors the total size of the p-code will be 
reported in the error log sub-window along with the maximum size that the application 
can be.  If the application goes over the limit, you can continue to increase the size of 
the application by breaking it up into two separate applications that call each other 
using the CASL launch command. 

C Build 

This will enable / disable the compiler from emitting C code. The C code is then 
compiled when the PRC file is made. A ‘C’ instead of a ‘CSM’ file is produced in the 
build directory. 

NOTE: You must have a CASL Professional Edition license file for this option to be 
enabled. 

Build Application Installer 

CASLinstall is used to create an install package that will install your PDA application, 
data files and conduit on your user's machine. It can be access from two CASLide 
menus: Project and Build menus. 
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The Build->Build Application Installer menu will do the same but position to the build 
tab. 

The Project->Application Install Settings menu will open the CASLinstall design dialog 
and position to the first tab. 

Make PRC 

In order to create a PRC file from a CSM p-code file, the PalmPilot desktop name and 
the unique creator ID for the application must be entered into the dialog box displayed 
by CASLide.  The dialog allows the creator ID to be entered as a one to four character 
long alpha numeric string. The desktop name and creator ID and other Application 
Settings are saved with the project and restored whenever the project is opened. 

NOTE: creator Ids should be registered with the Palm creator ID registry (see 
http://dev.palmos.com/creatorid/). 

After this information is entered, CASLide will produce a file with a suffix of PRC and a 
name the same as the CASL source file.  The PRC file is ready for installation into the 
PalmPilot. 

Before the PRC is made, the dates of the source files and CSM file are checked to see 
if a build must be done. There is a CASLide Settings option under the Tools menu item 
that enables and disables a prompt that confirms that the files should be rebuilt. 

If the C Build option was selected, then this will launch the C_Build.bat file that is used 
to compile the application and produce a PRC file. Please refer to the CASL 
Professional section for more information. 

This menu item is only enabled when the build configuration is "Pilot Release" or "Pilot 
Debug". 

Install PRC 

This command will install a created PRC file into the appropriate directory for 
download into the PalmPilot.  After this command is invoked, the PRC file will be 
downloaded into the PalmPilot on the next HotSync operation. 

http://www.palm.com)


                                                                                                                      CASLide 
Version 4.3 

 44

Before the PRC is installed, the dates of the source files, form files, CSM file, ICON file 
and PRC file are checked to see if a build must be done. There is a CASLide Settings 
option under the Tools menu item that enables and disables a prompt that confirms 
that the files should be rebuilt. 

This menu item is only enabled when the build configuration is "Pilot Release" or "Pilot 
Debug". 

Install CSM 

This command will install a created CSM p-code file into the appropriate directory for 
download into the PalmPilot.  After this command is invoked, the file will be 
downloaded into the PalmPilot on the next HotSync operation.  This file will only 
appear in the selection list display by the CASL runtime interpreter when it is initially 
started. 

Before the CSM is installed, the dates of the source files, form files, and CSM file are 
checked to see if a build must be done. There is a CASLide Settings option under the 
Tools menu item that enables and disables a prompt that confirms that the files should 
be rebuilt. 

This menu item is only enabled when the build configuration is "Pilot Release" or "Pilot 
Debug". 

PocketPC Install 

This will copy the CCE file produced by the PocketPC build, to the PocketPC install 
directory. The install directory is defined in the IDE Settings and should point to the 
directory that ActiveSync uses to copy files to the device. The folder must be enabled 
by ActiveSync using the Microsoft ActiveSync options menu. Select the Sync Options 
tab and check the Files checkbox. 
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The Execute Menu 
This menu contains the command start the Windows version of the CASL runtime 
interpreter to execute a CSM file that has been produced by the “Windows Debug” and 
"Windows Release" builds.  The Windows interpreter displays a window with the same 
aspect ratio as the Palm Pilot.  This allows CASL programs to be run on both the PC 
and PalmPilot with no changes.  Use the standard Windows close action to shutdown 
the runtime interpreter. 

The “Execute” menu commands are: 

Run Execute the release or debug build without debugging. 

Debug Execute the debug build and enable debugging. 

Breakpoint Toggle a breakpoint setting on a source line. 

Remove All Removes all breakpoints. 

Run - (key sequence Ctrl + F5) 

This will execute the Windows Release or Windows Debug builds. The debug 
information is ignored if the debug build is executed. 

This menu item is only enabled when the build configuration is "Windows Release" or 
"Windows Debug". 

Debug - (key sequence F5) 

This will execute the Windows release or debug build. If the debug build is executed, 
then the debugger is enabled allowing stepping through the application's execution. 
The release build is executed as though the Run menu item was selected, since there 
is no debug information in the output file. 

While debugging, a yellow arrow is displayed on the line that is to be executed next. 

This menu item is only enabled when the build configuration is "Windows Debug". 
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Breakpoint - (key sequence F9) 

This will toggle the breakpoint setting on the line containing the cursor. A red circle is 
displayed to the left of the line if a breakpoint is enabled for that line. Breakpoints can 
be set on non-executable lines such as comment, function statements, and variable 
blocks. The breakpoint is ignored, and in the future will not be allowed (CASLide does 
not have knowledge to parse the source code at this time). 

The breakpoints are stored with the project and restored when the project is re-
opened. 

This is not available for image files. 

Remove All Breakpoints - (key sequence Ctrl+F9) 

This will remove all of the breakpoints in all of the files that are set. 

This is not available for image files. 

The Debug Menu 
The “Debug” menu contains commands that are used to control the debug execution 
of the application. The menu items are disabled when the application is executing 
statements (i.e. it is not stopped at a breakpoint). A red circle marks lines that have 
breakpoints set and yellow arrow marks the line that is to be executed next. 

The “Debug” menu commands are: 

Step Execute the current line. 

Step Over Execute over a call. 

Run To Cursor Sets a temporary breakpoint at the cursor and resumes. 

Resume Resumes execution to the next breakpoint. 

Quit Debugger Quits debugger and exits the CASL application. 

Display Variable Allows watching a variable's value. 

Add Variable Adds a variable to the watch window. 
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Breakpoint Set or Clears a breakpoint. 

Remove All Removes all breakpoints. 

Show Next Show the line that is to be executed. 

Step - (key sequence F11) 

The marked statement is executed and control returns to the debugger on the next 
statement. The next statement to be executed is marked with a yellow arrow to the left 
of the line. 

Step Over - (key sequence F10) 

This is the same as Step unless the statement is a call. If it is a call, then execution 
resumes until the statement that follows the call, or the next breakpoint, whichever is 
encountered first. 

If the statement is an IF or ELSE_IF and contains a function call, then the program will 
not break if the condition is false. You will need to put a breakpoint in the block that will 
execute if the condition is false. 

Run To Cursor - (key sequence Ctrl + F10) 

A temporary breakpoint is set on the line marked by the cursor. Execution is then 
resumed until the temporary breakpoint, or normal breakpoint, which ever is 
encountered first. 

Resume - (key sequence F5) 

Execution is resumed until a breakpoint is encountered. If an event function (e.g. 
button-evoked function) is exited before a breakpoint is found, the application has 
control until a new event is triggered. The debugger menu items and toolbar items will 
be grayed until a breakpoint is encountered, and control returns to the debugger. 

Quit Debugger - (key sequence Shift + F5) 

Terminates the application and exits the debugger. 
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Display Variable - (key sequence Shift + F9) 

This will display a dialog box that allows looking at or changing the highlighted 
variable's value. The variable can also be added to or removed from the watch 
window. There are three watch windows, so they can be grouped in a logical manner. 
The refresh button will fetch the variable's value again. Changing the variable name 
and clicking refresh can reference a new variable. The Display Variable dialog can 
also be invoked by double clicking the variable in the watch window. 

The variable value will also be displayed if the debugger data popup feature is enabled 
and the cursor is over the name. 

Add Variable - (key sequence Alt + F9) 

This is similar to the Display Variable menu item, but adds the variable without going 
through the display dialog box. Highlight the variable and select the Add Variable 
menu item or right click to display the context menu and then select Add Variable. 

You can also select a variable in the watch window and then right click and select 
Delete Variable from the context menu. You can select one or more variables by using 
the shift and control keys as you would for doing multiple selections on other Windows 
applications. 

The selected variables are stored with the project and restored when the project is re-
opened. 

Breakpoint - (key sequence F9) 

This will toggle the breakpoint setting on the line containing the cursor. A red circle is 
displayed to the left of the line if a breakpoint is enabled for that line.  

The debugger stops at statements that are executed.  If you single step in the 
debugger through a simple IF.. ELSE... END_IF, you'll see that the ELSE isn't 
executed and the debugger skips over it. 

The ELSE_IF is essentially two statements together: an ELSE followed by an IF. 
The debugger is treating this as an ELSE when the IF portion evaluates to FALSE, 
and skipping past it to the next ELSE or ElSE_IF.  If the next ELSE_IF is also 
evaluating to FALSE, the debugger is skipping past that as well. 
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Breakpoints on multi-line statements must be set on the line that contains the 
semicolon. 

Breakpoints can be set on non-executable lines such as comment, function 
statements, and variable blocks. The breakpoint will be ignored, and in the future will 
not be allowed (CASLide does not have knowledge to parse the source code at this 
time). 

The breakpoints are stored with the project and restored when the project is re-
opened. 

Remove All Breakpoints - (key sequence Ctrl + F9) 

This will remove all of the breakpoints in all of the files that are set. 

Show Next – (key sequence Alt + Num + *) 

This will position the debug cursor to the next statement that will be executed. 

The Layout Menu 
The “Layout” menu contains commands used to size and align selected display 
objects on a form. For some only one object need to be selected, and for others two or 
more objects need to be selected. 

The “Layout” menu commands are: 

Align Align two or more controls. 

Space Evenly Space three or more controls and equal distance apart. 

Make Same Size Make two or more controls the same size. 

Center Center one or more controls on the form. 

Size To Content Size the control based on its display text. 

Grid Enable the layout grid. 

Lock Control Will lock a control so it can not be moved or sized. 
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Unlock Control Will unlock a control so it can be moved or sized. 

Align 

This will align the left, top, right, or bottom sides of two or more selected controls. The 
controls are aligned with the dominant control, which is shown with a hatched border. 

Left 
This will align the left side of all the selected controls to the dominant control, which is 
shown with a hatched border. 

Right 
This will align the right side of all the selected controls to the dominant control, which is 
shown with a hatched border. 

Top 
This will align the top of all the selected controls to the dominant control, which is 
shown with a hatched border. 

Bottom 
This will align the bottom of all the selected controls to the dominant control, which is 
shown with a hatched border. 

Space Evenly 

This will space three or more controls evenly apart, horizontally or vertically. The 
controls between the top and bottom (vertically) or left and right (horizontally) and 
spaced so there is equal space between all of the selected controls. 

Across 
Space them evenly from left to right on the form. 

Down 
Space them evenly from top to bottom on the form. 
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Make Same Size 

This will size two or more controls to the same width, height, or both. The controls are 
sized to the dominant control, which is shown with a hatched border. 

Height 
Set the height of all the controls to the same height of the dominant control, that is 
shown with a hatched border. 

Width 
Set the width of all the controls to the same width of the dominant control, that is 
shown with a hatched border. 

Both 
Set the height and width of all the controls to the same height and width of the 
dominant control, that is shown with a hatched border. 

Center 

This will center one or more controls on the vertical or horizontal axis. 

Vertically 
Center all of the selected controls between the top and bottom of the form. 

Horizontally 
Center all of the selected controls between the left and right sides of the form. 

Size to Content 

This will size one or more selected controls based on the display text. If the control has 
a bitmap, then the control is sized to fit the bitmap. 

Selectors, Files Selectors, and Frames are not affected by this command. 
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Grid 

An alignment grid can be shown to help position the controls on the form. 

A horizontal line is also shown near the top of the form. This represents the bottom of 
the title displayed on the PalmPilot form. 

These setting are saved with the project. 

Toggle Grid 
This will turn on and off the alignment grid. 

Snap to Grid 
If this is checked, then the control will move to the closest grid point. 

Grid Spacing 
This allows setting the grid spacing. 

Lock Control 

This will lock a control so it can not be moved or sized. 

Select one or more controls and then select lock, or press the right mouse button to 
display the context menu. There is also a checkbox on the property sheet that sets the 
Lock State of the control. 

Unlock Control 

This will unlock a control so it can be moved or sized. 

Select one or more controls and then select unlock, or press the right mouse button to 
display the context menu. There is also a checkbox on the property sheet that sets the 
Lock State of the control. 
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The Tools Menu 
The “Tools” menu contains commands that are capable of changing CASLide 
environment variables.  

The “Tools” menu commands are: 

IDE Settings  Change the CASLide settings. 

Customize   Customize the user extensible tool menu. 

Convert CDI to PDB Convert a CASL CDI/CDB file to a PDA PDB. 

IDE Settings 

IDE Settings 

This allows changing the CASLide settings. 

PalmPilot Install Directory 
The PalmPilot HotSync directory location can be modified.  The new directory location 
string is entered into the PalmPilot edit box or the browse button to the right of it can 
be used to locate the directory. This should be the PalmPilot HotSync directory for the 
user (e.g. c:\pilot\jsmith). 

PocketPC Install Directory 
This is similar to the PalmOS install directory, but is used for PocketPC installs. This 
should point to the directory that ActiveSync uses to copy files between the desktop 
and PocketPC device. 

The default directory is in the desktop “My Documents” folder and is named using the 
PocketPC device ID. The device ID can be found by going to the PocketPC Start-
>Settings->About->Device ID tab. The directory will be named “<device id> My 
Documents”. Most of the time this will be “PocketPC My Documents” if the default 
device name was not changed. 
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Font Settings and Editor options 
The font settings for the project tree, build window, variable watch window, and the 
editor can be individually customized from this menu item. 

The editor options can be changed using the dialog box that is displayed when this 
menu item is selected. Syntax coloring options can be modified and tab settings 
adjusted by this dialog box. 

IDE Form Size 
The IDE Form Size settings allow changing the form size used while laying out the 
form design. 

Restore last workspace 
The Restore last workspace box will enable reloading the last project when CASLide is 
started the next time. 

Assume project name same as source name 
The Assume project name same as source name will allow naming the project 
separately from the application source name. When this option is selected, a dialog 
box will be displayed when a project is created that allows naming the project. 

Confirm automatic save before build 
The Confirm automatic save before build checkbox will cause a message box to be 
displayed if CASLide is automatically saving the source files. CASLide attempts the 
automatic save before a compile, run, or PRC generation or install, if it sees that the 
input and output files are out of date. 

Confirm automatic build before run 
The Confirm automatic build before run checkbox will cause a message box to be 
displayed if CASLide is automatically building the project. CASLide attempts the 
automatic build before a run, or PRC generation or install, if it sees that the input and 
output files are out of date. 
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Add new form file to project 
The Add new form file to project checkbox will add a newly created form file to the 
project file set. 

Automatically check for duplicates 
The Automatically check for duplicates checkbox will check for duplicate object names, 
and duplicate selector list variable allocation. Duplicates can also be checked by 
selecting “Check for duplicates” in the Project menu. 

Allow Multiple CASLide's to run 
The Allow Multiple CASLide's to run checkbox will allow or disallow multiple copies of 
CASLide to run. If it is not checked then an attempt to start a second copy will bring 
the first CASLide to the foreground. 

Allow object property detection 
The Allow object property detection checkbox if checked will automatically display the 
Object Property popup. Please refer to List Object Properties for more detail. 

Show C build window 
If this is not checked then when you do a PRC build you will no longer see the compile 
in the DOS window. When the compile is finished you will see the output in the build 
output window just like a CSL build. If you double click on an error line it will take you 
to the file and line where the error occurred. 

See Project C Files for more information. 

Show Debugger Data Popups 
If this is checked then the value of the variable under the cursor will be displayed after 
a brief delay. This is only enabled when debugging an application. 

Customize 

Customize 
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User defined tools can be specified here. The user tools are added to the bottom of 
the Tools menu. The menu text, executable name, argument list, and working directory 
are specified for each tool defined. Several CASLide variables can be used when 
specifying the arguments and working directory. The project name and path are the 
same as the output file. 

$(ProjectPath) yields the directory location of the project. 

$(SourcePath) yields the directory location of the CSL file. 

$(ProjectName) is substituted with the name of the project. 

$(SourceName) is substituted with the name of the CSL file without the CSL extension. 

$(BuildPath) will give the directory location of the build output files. 

For example, if $(ProjectName).CSL is given in the arguments edit box, and the 
project name is Roster, then Roster.CSL will be passed to the user tool that is evoked. 

NOTE: The variable names ProjectPath, SourcePath, etc. are case sensitive. 

Convert CDI to PDB 

You can convert CASL CDI and CDB databases to a PDA PDB file. 

The CDI/CDB to PDB conversion dialog will use the CASL creator ID when the 
Project->Application Settings Database creator ID checkbox is not set, otherwise it will 
use the application creator ID. The creator ID is displayed and can be changed before 
the conversion is made. 

The record id and status fields in the CDI/CDB are ignored and are set to zero in the 
created PDB file. 

The function can also be performed using the ConvertCDI2PDB.exe utility. The 
command syntax is: 

ConvertCDI2PDB <filename> -CreatorID <id> -DisableBeam -Backup 

Where <filename> is the name of the CDI or CDB and <id> is your creator id. You 
must use quotes around the file name if it has spaces in it. If you do not specify the 
creator ID then the CASL creator ID is assumed. 
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The database will have the beam disable bit set if the –DisableBeam option is set. 

NOTE: The application that does the beaming needs to look at this bit and disable the 
beaming if set. It is not done automatically by PalmOS. 

The database will have the backup bit set if the –Backup option is set.  The PDB file 
will be copied to the HotSync user’s backup folder each time a HotSync is performed. 

NOTE: This should only be set for PDB files that do not have a HotSync conduit. 

 

This example will convert Test1.cdi to test1.pdb and assign Tst1 as the creator ID and 
set the backup bit: 

ConvertCDI2PDB "G:\Program Files\Temp\Test1.cdi" -CreatorID Tst1 -Backup 

This example will convert Test2.cdb to test2.pdb and assign CASL as the creator ID 
and will disable beaming: 

ConvertCDI2PDB "G:\Program Files\Temp\Test2.cdb" -DisableBeam 

The Windows Menu 
This menu provides the standard controls for switching between the currently active 
window on the display, creating a new window, splitting views, and tiling the currently 
open windows. 

The Help Menu 
The CASLide help sub-system is invoked with the commands from this menu.  The 
help database can be searched for a particular topic string, or be traversed by 
category.  The “About” command provides licensing information for the currently 
executing version of CASLide.  The help sub-system can also be accessed via the 
“F1” key. 
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Image Editing 
The CASL image editor is used to create PRC Icon and button/label bitmap files. 

Each CASL PalmOS project can have an icon associated with it. If the Icon is not 
specified (see Project Settings menu), then the default CASL Icon will appear on the 
PalmPilot desktop. 

There can be any number of bitmap files defined in a project. The size of the bitmap 
file can be changed using the Image menu Bitmap Properties dialog. NOTE: The 
bitmap will be cleared if the size is changed. 

The image editor can be launched from the project tree by double clicking the image 
file in the Images folder. The image file will be automatically opened in this case. 

If a very small bitmap is created (10x10) and stretched to fit a large form builder 
window (1024x768), the bitmap will distort. 

When creating a new monochrome image or modifying an existing one, the left mouse 
button is used to draw a black pixel, and the right mouse button is used to draw a 
white pixel. 

When creating a new color image or modifying an existing one, the left mouse button 
and right button have a selected color used to draw the pixel. The color is selected 
from the color toolbar that is shown when a color image is being edited. Position the 
cursor over the desired color and click either the left or right mouse button. 

The color RGB=0,128,128 is a transparent color which will replaced by the background 
color of the object it is placed on. You can select the transparent color by clicking the 
blue green box that is under and on the right of the Other button. 

Selected colors are changed to match the closest color in the PDA's color palette. For 
example a color value of hex 0x91a24f will change to hex 0x999966. 

The menu Image->Bitmap Properties allows setting the mode to monochrome or color. 

NOTE: The bitmap will be erased if you change the size or color mode properties. 
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A bitmap can consist of a color and monochrome bitmap image. This is called a 
bitmap family. If you want your application to run on color and monochrome devices 
then you will need to create a bitmap family consisting of a color image and a 
monochrome image. The device will decide which to display. The menu Image->New 
Bitmap Type and Image->Delete Bitmap Type are used to create bitmap families. 

The combobox on the Image Toolbar can be used to select the bitmap family image to 
be displayed. 

 NOTE: Bitmap families take more space than a single bitmap. Also once you 
create a bitmap family you will not be able to open the bitmap with earlier CASL 
releases or external image edition tools such as Window's Paint utility. 

See the Image Menu for a list of available drawing tools. 
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Form Builder 
The output of the forms builder is a CASL code file with the extension CFF (CASL 
Form File). The output file is automatically included before and after the CSL source 
file. The objects are defined before the CSL is compiled, and assigned modifiers after 
the CSL is compiled. 

Adding A Form 

Adding A Display Object 

Selecting A Display Object 

Display Object Properties 

Display Object Color 

NOTE: Please do not edit the form file with a text editor. The form builder 
expects a very particular format. 

Adding A Form 
Add a form to the project by selecting Project->Add Files... from the menu, and then 
selecting a form file (CFF). If the file does not exist, it is created. 

If the Tools->IDE Settings...->Add new form file to project is set, then the form will be 
added when the form file is saved, if it is not already in the project. 

Adding A Display Object 
Select a tool from the display object toolbar and then click the left mouse button at the 
desired location on the form. While holding the left button down, drag the display 
object to the desired shape. 

An existing display object can be selected, copied and then pasted to the same form 
or a different form. 

Delete all selected objects with the Del key. 

The display objects are: 
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Button 

Checkbox 

Drop_down 

File Selector 

Frame 

Grid 

Label 

Selector 

Text Field 

NOTE: If more than one form exists in a project, then they all should have a frame, 
otherwise the display objects without a frame may not display predictably. The frame is 
automatically created when a form is created using the form builder. 

Selecting A Display Object 
Click the display object or press the left mouse button and while holding it drag the 
selection rectangle over all of the objects being selected.  

Select multiple objects by clicking with the control key pressed. The last object 
selected is the dominant control (has a wider border). When aligning controls, all 
selected controls align with the dominant control. 

Holding the shift key while selecting an arrayed display object will select all of the 
members of the array. If you wish to keep previously selected objects then also hold 
the control key down. 

Form objects can be moved using the cursor keys. The Home, End, PgUp and PgDn 
are used to move diagonally. If the grid and snap are enabled then it will move one 
grid space unit, otherwise it will move one CASL Display unit for each key press. 

Display Object Properties 
Each display object has a set of properties, position, size, name, etc. Double click a 
control to get its property sheet. If a frame is present, then clicking on the surface (and 
not on a control) will display the frame's property sheet. 
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If the object is an array of objects, then the properties for all of the members will be the 
same except for the position and color of each member. 

The property sheets are: 

Common Properties 

Button Properties 

Checkbox Properties 

Drop_down Properties 

FileSel Properties 

Grid Properties 

Label Properties 

Selector Properties 

Text Properties 

Common Properties 

Each display object has a common set of properties. These are on the first tab of the 
object’s property sheet. 

Array Size 
If this is greater than zero then the object is an array of objects. The index text box to 
the right will show the index number of the selected object (minus one is not an array). 
If the number is increased, then new objects are added to the end of the array and 
initially will have the same position as the object that was changed. If the array size is 
decreased, then objects are removed from the end of the array. 

Background Color 
This will display a color selection popup that is used to select the object's background 
color. 

See Display Object Color for more information. 
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Font 
This defines the font used for the text displayed by the object. One of the standard 
PDA fonts can be selected or a special font can be selected using the “Font…” button. 

Note: Special fonts only apply to applications running using CASLwin. 

Hidden 
The object will initially be hidden if this is checked. 

Locked 
Checking this will prevent the object form being moved or sized on the design form. 

Name 
This is the name of the object and the name used when referencing the object in the 
source code. The name must be unique in the project (except for an array of the same 
object). 

Names can consist of the letters A-Z, a-z, number 0-9 and the underscore ‘_’. Names 
can not start with a number. 

Text Color 
This will display a color selection popup that is used to select the object's foreground 
color. 

See Display Object Color for more information. 

Use System Colors 
If this is checked then the object will used the system's color settings for the text and 
background. The Text and Background colorwells are disabled when this is set. 

See Display Object Color for more information. 

Width and Height 
These two properties show the size of the object. The object size can be changed by 
selecting and dragging its border or these values can be changed in the property 
sheet. 
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X Position and Y Position 
These two properties show the position of the object. The object position can be 
changed by selecting it and dragging it to a new location or these values can be 
changed in the property sheet. 

Button Properties 

These are the properties for a button object in addition to the common properties. 

Display 
This will be the text shown on the object. If this is left blank, then the text shown will be 
the Name property. 

If the Expression check box is set, then a CASL expression can be used and the result 
of the expression will be shown on the object. 

For example, char(61) + “>” will display => on the object if the expression check box is 
checked. If it was not checked, then the literal char(61) + “>” would be displayed. 

Global and local variables cannot be used because they have not been declared (i.e. 
nothing has been compiled at design time). 

NOTE: If the expression check box is set and a string is entered, then you must 
enclose the string entered in the display text box in quotes. For example, “Click Me” 
would display Click Me, without the quotes, CASLide will display an error. 

Expression 
If the Expression check box is set, then a CASL expression can be used and the result 
of the expression will be shown as the display property for the object. 

Bitmap 
This will display a dropdown of all the images in the project for a button or label object.  
If a button or label is an array, then any elements that have the bitmap name empty 
will use the bitmap of the first element of the object array. 

Invokes 
This property defines the function that is invoked when the object triggers an event. 
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When you click on the browse button the invoker function is searched and if found, the 
source file is displayed and positioned to the invoker function. If the invoker function is 
not found, then an error is displayed. This function is also accessible by the Edit menu 
item Go to Invoker.  

Border 
This is used to change the border style. 

Button Map 
This will display a dropdown of the available hardware buttons that can be associated 
with a non-arrayed button object. If the associated hardware button is pressed, then 
the button object's invoker function will be executed. 

The hardware button is active even if the form containing the bound button object is 
not shown. 

Format 
Numeric data is converted to a string before it is stored in the display property. The 
format modifier is used to convert the numeric to a string and is the same format string 
that is used by the string() function when converting a numeric to a string. 

Checkbox Properties 

These are the properties for a checkbox object in addition to the common properties. 

Display 
Please refer to the button Display property description. 

Expression 
Please refer to the button Expression property description. 

Format 
Please refer to the button Format property description. 
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Invokes 
Please refer to the button Invokes property description. 

Drop_down Properties 

These are the properties for a drop_down object in addition to the common properties. 

Display 
Please refer to the button Display property description. 

Expression 
Please refer to the button Expression property description. 

Format 
Please refer to the button Format property description. 

Invokes 
Please refer to the button Invokes property description. 

List 
The contents can be defined in the forms builder instead of the CSL code. The 
Selector's string array is generated if the list size is greater than zero. If the list size is 
zero, then just the reference is put in and the array will have to be allocated in another 
selector or in the source code module (CSL file). This way one selector can define the 
list and another can also use it, but not define it.  Click on the browse button (button 
with dots) in the List edit box on the property page to invoke the dialog that lets you 
define the list array contents. 

NOTE: Do not put a reverse slash before the closing quote of the string ("This is 
bad\"). The compiler will treat it as an embedded quote and the string will not be 
terminating with a closing quote. 
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List Height 
This controls the height of the drop_down selection list and is in CASL display units. If 
it is too small then nothing will be shown. On the PDA you must set this to show at 
least two or more lines. 

No Input 
This is used to set the field to read only when checked. 

FileSel Properties 

These are the properties for a file selector object in addition to the common properties. 

Display 
Please refer to the button Display property description. 

Expression 
Please refer to the button Expression property description. 

Invokes 
Please refer to the button Invokes property description. 

Grid Properties 

These are the properties for a grid object in addition to the common properties. 

Change column sizes by selecting the grid and then move the cursor over a column 
division. Press the left mouse button and drag it left or right.  

Display a Grid's cell properties by double clicking the cell in the grid. Only a few 
properties can be changed when the row is not zero. Use row zero to change the base 
properties. Base properties have the same value for all rows.  

A tab on the Grid property sheet represents each column. The last tab is used to add 
new columns.  
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The Grid property page has a column placement section that is used to move and 
delete columns.  

Column widths are expressed as a percentage of the overall grid width. If more than 
100% of the grid width is used, then columns starting from the right will be adjusted 
when exiting the Grid properties. Likewise the last column is expanded if less than 
100% is used.  

Column division lines are shown when the display-positioning grid is turned on.  

Bitmaps are centered in the cell.  

Labels are centered vertically in the cell.  

If single line mode is enabled then the text object will be centered vertically in the cell.  

The bound field sets the source of data for the column. It is the string or numeric array 
name or it could be the database object dot field. For example: 
 
dbfile myfile; 
field x1; 
end; 
 
You would use myfile.x1 in the bound field. 

Row Loaded Invoker 
This property defines the function that is invoked when a grid row is loaded. The 
invokersub built-in variable contains the display row number. 

When you click on the browse button the invoker function is searched and if found, the 
source file is displayed and positioned to the invoker function. If the invoker function is 
not found, then an error is displayed. 

Row Unloaded Invoker 
This property defines the function that is invoked when a grid row is unloaded. The 
invokersub built-in variable contains the display row number. 

When you click on the browse button the invoker function is searched and if found, the 
source file is displayed and positioned to the invoker function. If the invoker function is 
not found, then an error is displayed. 
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Selected Row Invoker 
This property defines the function that is invoked when a grid row is selected. The 
invokersub built-in variable contains the display row number. 

When you click on the browse button the invoker function is searched and if found, the 
source file is displayed and positioned to the invoker function. If the invoker function is 
not found, then an error is displayed. 

Display Rows 
The number of display rows are controlled by this property. 

Data Rows 
This sets the initial number of data rows. If a bound data source contains a greater 
number of rows, then the number of data rows will be changed at runtime to match the 
largest bound data source. 

Scrollbar 
This enables or disables the grid scroll bar. 

Border 
A grid can have the following border styles: 

None: No border or grid lines. 

Outline: A border around the grid. 

Column: Column grid lines and a border. 

Row: Row grid lines and a border. 

Both: Column and row grid lines and a border. 

Select Enabled 
If this is checked then the grid selection is disabled initially. 
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Column Placement 
This is used to move and delete grid columns. 

Select a column name from the “Delete column” dropdown to delete a colmn. 

Select a name from the “Move column” dropdown to set the column being moved. 
Then select “Before” or “After” and then select the destination column in the next 
dropdown. The column being moved will be moved “Before” or “After” the selected 
destination column. 

Columns Definitions 
The grid column properties are the same properties used by the button, label, 
checkbox, text and drop_down objects. 

Label Properties 

These are the properties for a label object in addition to the common properties. 

Bitmap 
Please refer to the button Bitmap property description. 

Display 
Please refer to the button Display property description. 

Expression 
Please refer to the button Expression property description. 

Format 
Please refer to the button Format property description. 

Selector Properties 

These are the properties for a selector object in addition to the common properties. 
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Invokes 
Please refer to the button Invokes property description. 

List 
Please refer to the drop_down List property description. 

Text Properties 

These are the properties for a text object in addition to the common properties. 

Display 
Please refer to the button Display property description. 

Expression 
Please refer to the button Expression property description. 

Format 
Please refer to the button Format property description. 

Invokes 
Please refer to the button Invokes property description. 

No Input 
This is used to set the field to read only when checked. 

Single Line 

This will enable horizontal scrolling if the text is wider than the object. Horizontal 
scrolling is always enabled on PalmOS devices. 

This will also vertically center the text object if it is in a grid cell. 

Scrollbar 
This will enable the scrollbar on text objects when set to Top or Bottom.  
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There are three types of scrollbar settings: 

None: No scrollbar 

Top: The cursor will be positioned at beginning of the text as text is added. 

Bottom: The cursor will be positioned at the end of the text as text is added. 

Display Object Color 
The Project Settings dialog now has two color wells for text color and background color 
and a Use System Colors checkbox. These are used as default settings for newly 
created objects (i.e. not one loaded from an existing form file). 

The object property page also has these, but for the specific object. The object 
property page is where you can customize the text and background color of a CASL 
display object. Leaving the Use System Colors checkbox set will make it look like 
CASL 3.1 and earlier. 

Checkboxes and label objects do not have a background color setting and will use the 
frame's background color. 

Each element of an array object can have different colors, but the "Use system color" 
setting can only be changed on the base object (i.e. element 0). 

A foreground and background object property has been added to allow changing the 
object color at runtime. The color is expressed as a RGB value (red green blue). Each 
color range is from 0 to 255 where 0 is no color. A RGB color value is red + 256 * 
green + 65536 * blue. Palm OS only supports web safe colors (about 225 colors) and 
CASL will change the set color to match the closest Palm color. 

There are two new functions for color. The first is a rgb(red, green, blue) function that 
will return the color value given a red, green and blue value from 0 to 255 where 0 is 
no color. The second new function is called color_depth() and will return the number of 
bits used to display colors. A return value of 1 indicates monochrome, 4 is 16 colors 
and 8 is 256 colors. 

PalmOS 3.5 and above monochrome devices allow black and white coloring. For 
example you could change a button to have white text and a black background. Setting 
the ‘Allow 1-bit color control’ checkbox on the Project Settings dialog enables this. 
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NOTE: A show or setting the hidden property to 0 must be done after changing an 
objects color, size, bitmap or position. This is left to the application in case there is 
more that one property being changed on a single object. This helps reduce the 
processing overhead of automatically doing each object as each object property 
changes when only one show is needed after all the properties are set. 

NOTE: The background color is set to the frame's background color when the no_input 
property set to 1. 
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Installing the CASL Conduit 
If you are going to distribute a CASL application that uses databases, then you will 
need to install the CASL Conduit on your end users machine.  

You need to run the CASL conduit registration utility CondReg.exe with the path to the 
CASL conduit DLL CASLcn20.dll specified on the command line. For example, if the 
CASL conduit DLL were in E:\CASL, then you would use: 

CondReg.exe “E:\CASL” 

NOTE: There is no trailing backslash. If the path name contains spaces, then it 
will need to be enclosed in quotes. 

This will copy the DLL from the specified location to the PalmPilot install directory, and 
register the CASL conduit with HotSync. The PalmPilot HotSync software must be 
installed first. 

NOTE: HotSync Manager must be restarted after installing the CASL conduit. 

If the database creator ID is set the same as the application creator ID, then a CASL 
HotSync registry entry must be created for the application. The following CONDREG 
command line options are available to do this. If you do not specify any one of the new 
arguments, then CASL will be used for the one(s) not set. 

NOTE: Do not use the same directory for applications with different creator Ids. 

-AppName "name" 
Name is a quoted string that is displayed during HotSync. 

-CreatorID id 
Id is the application creator ID. 

-Directory "dir" 
Dir is a quoted string that is the directory that is under the user's HotSync directory and 
is where the databases are read from and written to during the HotSync operation. 

For example: 

CONDREG "C:\CASL" -AppName "Fred's App" -CreatorID FRED -Directory "Fred Dir" 
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This will copy the CASLcn20.dll from C:\CASL and create a HotSync registry entry that 
is called ApplicationFRED. The creator ID is set to FRED and the databases will be 
written to the directory called Fred Dir, which will be under the user's HotSync 
directory. HotSync will display Fred's App when it HotSyncs the databases. 

The utility REMCOND is used to remove a CASL HotSync conduit registry entry. There 
are three optional command line arguments: 

-CreatorID id 
Id is the application creator ID. If you do not specify -Creator ID, then the CASL entry 
will be removed. 

-KeepDLL 
If this is specified, the CASL conduit DLL will not be deleted. 

-Silent 
Using this will remove the prompt that asks if you are sure you want to remove the 
conduit and will remove the prompt that indicates the conduit has been removed. Error 
prompts will still be shown. 

Here is an example: 

REMCOND -CreatorID FRED -KeepDLL 

This will remove the HotSync registry entry called ApplicationFRED and will not delete 
the CASL conduit CASLcn20.dll. If you do not specify any of the new arguments, then 
CASL will be used as the creator ID and the CASL conduit will be deleted. 

Installing DLL’s 

The following DLL’s must be in the Windows System32 directory or in the directory, 
which CondReg or CASLwin is executed from. You should never overwrite a new DLL 
with an old DLL. It is best to use a Windows installer such as InstallShield when 
installing DLL's since it will check the version code (msvcrt.dll 6.0.8797.0 should not 
replace 6.1.9359.0). Checking the date can be misleading. If you do not want to check 
the version then you must put the DLL’s in the same directory as the application. This 
way the application has what it needs and other applications do not end up using an 
older DLL. 

MFC42.DLL 
MSVCRT.DLL 
MSVCRT.DLL 
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Files That Can Be Redistributed 
Licensee may distribute the runtime, and conduit files with their CASL applications on 
a royalty free basis. The file set is: 

CASLwin.exe CASL Windows (95, 98, 2000, NT, XP) runtime 

CASLrt.prc CASL PalmOS runtime 

CASLppc.exe CASL PocketPC runtime 

CASLCn20.dll CASL Conduit 

CondReg.exe CASL Conduit HotSync registration 

RemCond.exe CASL Conduit HotSync unregistration 

ConvertCDI2PDB.exe CASL PalmOS database conversion utility 

CASLcdi2ppc.exe CASL PocketPC  database conversion utility 

CASLcopy.exe CASL install utility 

Setup.exe CASL install runtime 

CASL*.fnt CASL Fonts 
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Installing CASLwin 
CASLwin requires the following DLL’s to execute. Please read Installing DLL’s and 
Files That Can Be Redistributed for further information. 

MFC42.DLL 
MSVCRT.DLL 
MSVCRT.DLL 
 

The CASL fonts will need to be copied to the Windows/WinNT Fonts directory if the 
Use CASL fonts option was set in the Project Settings.  

The screen size is derived from the CSP file and the size was set using the Project 
menu item called Project Settings. This can be overridden using the ScreenSize 
option. 

The screen size can be changed in the Project Settings and will be set in the CSP file. 
This setting can be overridden using the -ScreenSize option. 

The size of the CASLwin runtime can be changed using the –ScreenSize option. If 
zero is used, then the runtime will size the screen the way it did before the 2.5 release 
(i.e. works the same as the 2.53 and earlier released versions). If the –ScreenSize 
option is not specified, then the screen size in the CSP file will be used (suggested 
method). 

The -ScreenSize option has two arguments, height and width. For eample: 

-ScreenSize 160 0  Form will be 160 wide and 160 tall 

-ScreenSize 200 190 Form will be 200 wide and 190 tall 

Note: The -ScreenSize option follows the CSP filename. 

CASLwin "C:\Project Files\CASL\Fred.csp" -ScreenSize 320 320 

The CASLwin option –EscapeEnabled can be set TRUE to allow the application to 
shutdown if the escape key is pressed. By default the escape key is disabled, however 
this option is set TRUE when CASLwin is launched from CASLide.  
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A shortcut can be configured to launch a CASL application. For the shortcut target, 
specify the full path to CASLwin in quotes, followed by the full pathname to the CASL 
application in quotes. If desired, you can optionally add the –ScreenSize option. Set 
the full pathname of the directory of the CASL application, in the ‘Start in’ edit box. 

Here is an example of a shortcut’s settings: 

Target: "C:\MyDir\CaslWin.exe" "C:\MyDir\MyApp.csp" -ScreenSize 320 320 

Start in: “C:\MyDir” 

Run: Normal Window 
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Installing CASLppc 
There is a new folder under the CASL install folder called “PocketPC Files”. This folder 
contains the CASL PocketPC runtimes for ARM, SH3 and MIPS CPUs. To install the 
runtime, connect your PocketPC PDA via ActiveSync and then double click on the 
“PocketPC Files\install.bat” file. This will install CASLppc.exe into the \Program 
Files\CASLsoft folder on the PDA and add a shortcut to the Windows\Start 
menu\Programs folder. From the Settings>Menu dialog you can add the CASL runtime 
to the Start menu. 
 
These are the steps to install your application on the PDA: 

 Enable the Files sync option from the ActiveSync Sync Options tab and set the 
path to the same path that you define in CASLide Tools>IDE Settings>PocketPC 
install directory.  

 Make sure the build is set for “PocketPC Release” or “PocketPC Debug”.  

 Compile your application.  

 Select PocketPC Install from the Build menu. ActiveSync will detect that the file 
was written and will copy it to the PDA under you My Documents folder.  

Your application can be started by selecting CASLppc from the Start menu or by 
clicking the dot CCE file that was installed. 

CASLinstall can also be used for installing CASL PocketPC applications. 
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CASL Databases 
The CASL database file format is a variation of the comma-delimited format used by 
other Window applications. CASLwin uses this format when reading and writing the 
database. The CASL conduit also uses this format when transferring the database to 
the hand held device. 

The PocketPC version of CASL uses the Palm creator ID for its DBFILES and FileSel 
objects. The creator ID and Desktop name is set using the CASLide menu 
Project>Application Settings. 
 
The CASL dbfiles are in the PocketPC Object Store database and will be synced 
(to/from/merge) when the ActiveSync module is completed. The files will be in 
CDB/CDI format on the PC and in Object Store format on the PDA. 

The PocketPC database is not a CDB file on the device. The CASL dbfile is in the 
object store. When the ActiveSync CASL desktop and device providers are completed, 
the desktop CDB/CDI will be transferred to/from/merged the device. 

The is a CASL utility called CASLcdi2ppc which can be used to transfer a CASL CDI 
or CDB file from the Windows PC to the PocketPC device. 

CDB Format Format definition of CASL database files 

CDI Files A form of a CDB used to create a database on a hand held 

CDB Format 
If you open a CDB file with a standard text editor, you will see a number of lines at the 
top that starts with a pound sign ‘#’. These are header records and describe the file 
version, number of records, and the record structure. The remaining records are data 
records. 

The lines beginning with the pound sign are the file header lines.  

#CDBID: CASL Identifies the file as being a CASL file. This is not the 
application creator id and must always be set to CASL. 

#MAJREV: 2 Major revision (must always be set to 2).  
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#MINREV: 0 Minor revision (must always be set to 0).  

#FLDCNT: 1 Number of fields per record (1 field in this example).  

#RECCNT: 1 Number of records (1 record in this example).  

#SYNCMODE: MERGE HotSync mode (set to merge in this example).  

The allowed values for #SYNCMODE are: 

MERGE Typical transfer.  

PC_TO_PDA PC overwrites the PDA  

PDA_TO_PC PDA overwrites the PC  

NO_SYNC No transfer is performed 

NOT_SPECIFIED External control (same as MERGE for now)  

The field definition format is #FLDNUM:N TYPE:T SIZE:S, where N, T and S are 
defined as: 

N Field number starting with 1 and ending with the field count specified by #FLDCNT 

T S-string, N-number, NA-Number array, BA-Byte array  

S Number of elements if array, else it is zero  

Data Records 

There will be #RECCNT data records that follow the header records. The first field is 
the record ID field and is assigned by the PDA. You should not assume anything about 
the value of this field. When new records are added on the PC side, it is set to zero, 
0x00000000. The next field is the status field. This can be a combination of the 
following values:  

0x0001 Used during HotSync.  

0x0002 Record has been marked for deletion.  
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0x0004 The record has been modified.  

0x0008 This is a new record.  

NOTE: The record ID and status fields must be set to 0x00000000, 0x0000 for CDI 
files. 

The fields that follow the status field contain the applications data. String fields have 
double quotes surrounding them. If a double quote is part of the string, then it has 
double quotes around it. If a field is empty, then it still needs a comma as a 
placeholder. Here are some examples:  

0x00D1C004,0x0000,"David",,0,"","" The field after David is empty.  

0x00000000,0x0008,"Ethel",,0,"Hi ""Mike""","" Mike is quoted.  

0x00D1C005,0x0000,"Fred",100,0,"one, two","" String “one, two” has embedded 
comma.  

Numeric fields must also have quotes around them if a comma is used as the 
separator between the integer and fractional part of the number. The quotes are 
optional if the period is used as the separator. CASL will reformat the number when 
reading so that it matches the regional setting of the machine. In other words it does 
not matter if you have "123.456" or "123,456", CASL will make the adjustments when 
converting the text format to the binary format. 

CASL will use the regional settings when writing the database file to convert the binary 
format to the text format. For example if your regional settings are set to the US, then 
the number will be output with the period as 123.456 (without the quotes to maintain 
compatibility with earlier databases). If your regional settings are France then the text 
version of the number will be stored with the comma as "123,456" and will have quotes 
surrounding it. 

When the CASL conduit reads a data file from the PDA it does the following 
conversions: 

Another single quote is added to a single quote if ODBC 
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Another double quote is added to a double quote if not ODBC 

Carriage returns are stripped if not ODBC 

Linefeeds are converted to \n if not ODBC 

When the CASL conduit sends a data file to the PDA it does the following conversions: 

Two double quotes are converted to a single double quote 

\n is converted to carriage return linefeed 

We reserve the right to change the format of the CDB file at any time. If we do, then 
the major revision will change if there is a massive structure change that is not 
handled automatically. If there is a slight change then the minor revision will change 
and the database subsystem will take care of the conversion.  

CASL Database Install (CDI) 
Normally CASL databases are only transferred by the CASL conduit if they exist on the 
hand held device. A CASL application is run on the hand held to create the CASL 
database for the first time. If you do not want to create the database on the hand held 
first, then a CASL Database Install file (CDI) must used to create a CASL database 
from the PC. 

The CASL database filename must end in CDI (CASL Database Install) and must be 
placed in your user's hand held CASL database directory, where the CDB files are 
normally located. 

NOTE: The name is upper and lower case sensitive. The CDI file name must match 
the case of the file name used to open the database file on the hand held device. 

The CASL database install file is just a CASL database file with the CDB file extension 
changed to CDI. 

NOTE: The record number and status flag fields must be set to zero. Please refer to 
the CDB data record structure for more information. 
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The conduit first does a normal transfer. It then looks for files with an extension of CDI. 
For each one, it does the following: 

1. Strips off the CDI extension. 

2. Deletes the database on the hand held by that name. 

3. Creates a new database on the hand held by that name. 

4. Copies the file from the PC to the hand held. 

5. Deletes the CDB file from the PC. 

6. Deletes the BAK file from the PC. 

7. Renames the CDI to CDB. 

8. The BAK file will be created on the next transfer. 

A new CDI header line has been added for ODBC support. It must follow the 
SYNCPREF line and its format is: 

#DSN: <data source name> 

Where <data source name> is a valid ODBC data source name. The name must not 
be longer than 31 characters and may contain spaces.  The database created on the 
PDA will use ODBC when it is processed by the CASL conduit during future HotSync's. 

One a dbfile has been created on the PDA, it will always retain if it was ODBC 
enabled. You can not change this unless you delete the dbfile and recreate. The dbfile 
data_source_name property string can change however. You can define a new ODBC 
data source name prior to opening the file.  
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ODBC Support 
First, make sure you create an ODBC Data Source Name (DSN) using the ODBC Data 
Source Administrator in the Control Panel folder. There are problems with Access 
ODBC if the database is create via the Create... Button while you are defining the 
Access ODBC DSN. CASL can not open the database nor can Access. Create the 
database using Access and not via the ODBC setup. 

The field names are not carried in the object code so they are automatically 
constructed. They are called FLD_n_t where n is the field number and t is the type: S 
for string and N for numeric. 

The first two fields are for the record ID (long int) and status (short int) and must exist. 

You can create the tables ahead of time and give them better column names if you 
would like. Just make sure that the number of fields and the types match your code. 
Also, remember to have the REC_ID and REC_STATUS fields first. 

You can add keys and indexes to the tables but just make sure the first index is on the 
first field and is ascending. 

The file selector object does not know about DSN's. 

The delete command does not know about DSN's. 

The Excel and Text ODBC drivers do not allow updates. You can only create once but 
can read always. 

The conduit is not creating the backup ODBC database so a slow sync will not work. A 
slow sync is done when you sync a PDA on two computers. The first computer will do 
a normal sync and the second computer will do a slow sync. 

ODBC does not know about Palm users. If each user has the same DSN then they will 
all write to the same database. You can set the dbfile's data_source_name property 
any time before opening the file. 

The data_source_name dbfile object modifier must be set when the dbfile object is 
defined if you are going to change the name. 
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CASLcdi2ppc Database Transfer Utility 
CASLcdi2ppc will transfer a CDI/CDB dbfile from the desktop to the PocketPC device. 
 

Command line option Description 

-CreatorId XXXX  Where XXXX is your creator id 

-DbFile DbFilePath Where DbFileName is the name of the file to 
transfer. You may specify multiple –DbFile 
options to transfer a select group of files. The 
path name can use wildcard characters to 
specify a group of files. 

NOTE:  The name must be in quotes if it 
contains spaces. 

If no command line options are specified, then a dialog box is presented. 

Example Usage: 

    caslcdi2ppc -CreatorID MyApp -DBFile c:\myapps\coolapp\theDBFile.cdb 

 

file:///c:/myapps/coolapp/theDBFile.cdb
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CASLppc2cdb Database Transfer Utility 
This will transfer CASL DbFiles from the PocketPC device to the desktop PC. The file 
created on the PC is a CASL CDB file. 

Command line option Description 

-CreatorId XXXX  Where XXXX is your creator id 

-TransferAll This will transfer all DbFiles match the given 
creator ID 

-DbFile DbFileName Where DbFileName is the name of the file to 
transfer. You may specify multiple –DbFile 
options to transfer a select group of files. 

NOTE: This is not used if TransferAll set. 

-DestinationFolder The folder where the CDB files is created. 

NOTE:  The name must be in quotes if it 
contains spaces and must not have a trailing 
backslash. 

If no command line options are specified, then a dialog box is presented. 

*Example Usage: 
    caslppc2cdb -creatorid MyApp -DbFile MyDB -DestinationFolder c:\myapps\coolapp  

*Note - There should not be a trailing "\" at the end of the destination folder 
name. 

 

Note: The #SYNCMODE is currently always set to "NOT_SPECIFIED" 



                                                                                                                      CASLide 
Version 4.3 

 88

CASL Professional Edition ( C generator ) 
The C_Build directory contains the support files necessary to upgrade the CASL 
environment to the new Professional Edition, which provides the ability to translate 
CASL projects into C source code, and compile and link that source code (with a 
CASL support library) into a standalone PRC file. 

The compile / link process is seamlessly integrated into the CASLide.  A new "Build" 
menu option (C Build) toggles the CASL environment between creating p-code based 
Pilot executables or C-code based executables.  When the "C Build" option is set, the 
CASL compiler will generate C code, and the "Make PRC" option will invoke a batch 
file that will perform the C compile and link process, using the GNU GCC compiler. 

C Build applications can have a user-specified creator ID by checking the Database 
creator ID checkbox on the Project->Application Settings dialog. A CASL conduit can 
be configured for the new creator ID using the CASL conduit tool. 

If you are going to write external C functions then please read C_Guild.txt which is in 
the CASL43\C_Build folder 

CASLpro Installation Info 
The CASL compiler will generate C code compatible with the latest CASLpro support 
library, allowing CASLpro programs to now run on PalmOS 5.0 devices. 

Once the CASLpro compiler and the PalmOS 5.0 SDK have been installed, the 
CASLpro environment can be used to create applications that will run under PalmOS 
5.0. 

The CASLpro 4.0 version requires the use of PalmOS SDK 5.0, which can be 
downloaded and installed from our GCC install page 
http://www.caslsoft.com/gccinstall.htm.  See step 4. 

NOTE: In CASLpro 4.1, the support library 'pda_' functions no longer start with an 
underscore, as they did in CASLpro 3.3.  For example, '_pda_any_dispose' is now 
called 'pda_any_dispose'. For many of these, we've created #define 'aliases' in 
CASL_support.h, like this: 

#define _pda_any_dispose pda_any_dispose 
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So external C functions that we're used with CASLpro 3.3 wouldn't get syntax errors       
when compiling with CASLpro 4.1. 

If you had an external C function that called a CASLpro support library function using       
an underscore, and with CASLpro 4.1 are getting a GCC compiler syntax error, you 
can add you own alias to CASL_support.h (in the C-build directory) to get around the 
problem. Then send us an email to let us know you did it, and will add your alias to 
CASL_support.h in the next release. 

Additional information can be found on our web site: 

Gcc install  http://www.caslsoft.com/gccinstall.htm 

CASLpro FAQ http://www.caslsoft.com/caslprofaq.htm 

Project C Files 
C files can be added a CASLpro project by either creating them via File->New or by 
Project->Add Files. You will see two new folders, C Files and Header Files. Header 
files are included by scanning the C files just as CPKs are done. You can have 
multiple C files in a CASL project. The sample PixelWidth in the CASLpro Samples 
directory has been updated to use project C files. 

You no longer need use CASL_optional.c and CASL_optional.h in your project. 

Create a new C file from CASLide's File->New menu and move the code from 
CASL_optional.c to the new C file. If you had other C files being included from 
CASL_optional.c then just add those files to the project using the Project->Add Files 
menu and remove the include directives from your code. 

If you wish to keep using CASL_optional.c and want to add it to the project then you 
must include the following statements at the top of CASL_optional.c: 

#include <CASL_support.h> 

#include <CASL_prototypes.h> 

When a new C file is created these includes are added. If you use another editor to 
create the C file then you must add the above include directives to the top of the file. 

http://www.caslsoft.com/gccinstall.htm
http://www.caslsoft.com/caslprofaq.htm
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If CASL_optional.c included other C files and you wish these to be part of the project 
tree then you must remove these C includes directives and then add the C files to the 
project. 

You can build an existing CASLpro project without using the C file feature by not doing 
anything (i.e. don't add any C files to the project), but at some point you should move 
to the new c_build method. 

When you do a PRC build you will no longer see the compile in the DOS window. 
When the compile is finished you will see the output in the build output window just like 
a CSL build. If you double click on an error line it will take you to the file and line where 
the error occurred. 

NOTE: Do not name your C files the same name as your CSL file since the compile 
produces a C file by the same name. Also do not name then startup or shutdown since 
these are reserved for the compiler. 

NOTE: The pause in the c_build.bat file has been removed (among other changes). If 
you use the old c_build.bat file then CASLide will appear to hang when doing the gcc 
phase. 

NOTE: Windows Me does not support changing the environment space from 
Config.sys at startup. Windows Me users must first setup the MS-DOS environment 
space for c_build.bat. Double click on the c_build.bat file that is in the 
CASLsoft\CASL33\C_build directory then: 

1. Right click the title bar of the MS-DOS window and select properties. 

2. Click the Memory tab. 

3. In the Initial Environment box, set the initial environment size to 4096. 

4. Click OK. 

5. Close the MS-DOS window. 

The CASLide Show C build window checkbox in the Tools->IDE Settings must also be 
checked for Windows Me users. 

Please read CASL33\C_Build\C_Guide.txt file for more details on how interface C 
functions to CASL functions. 
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CASLinstall 
CASLinstall is used to create an install package that will install your PDA application, 
data files and conduit on your user's machine. It can be access from two CASLide 
menus: Project and Build menus. The Project->Application Install Settings menu will 
open the CASLinstall design dialog and position to the first tab. The Build->Build 
Application Installer menu will do the same but position to the build tab. 

The function of each tab: 

Application Information: This is where your application name, company name and 
version are set. This information will be displayed on the CASLinstall dialog when the 
install script is executed. It will be displayed as: 
 
Installing <Application name> <Version> <Company name> 
 

Setup Dialogs: Dialogs can be defined that show during the install process. 
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Welcome Bitmap File: This is a Windows BMP file and should be sized 460 by 280 
pixels. Depending on the target machine's system font settings, this can really range 
from 460x280 to 615x350. If it is too big then it will be clipped evenly around the 
edges. If it is too small then the background will be filled in with the bitmap's top left 
corner pixel color. 
 
Software License File: This is a text file that contains your software license agreement. 
The user has two options, proceed with the install if they choose "I Agree" or to cancel 
the install. The text is word wrapped in the display and can be a maximum of 65000 
characters. 
 
Setup Prolog File: This is a text file that is shown before the user selects a PDA user 
and starts the install process. The text is word wrapped in the display and can be a 
maximum of 65000 characters. 
 
Setup Epilog File: This is a text file that is shown after the install process finishes. The 
text is word wrapped in the display and can be a maximum of 65000 characters. 
 
Show Progress Indicator: If this is checked then a progress bar is shown. Because an 
install is usually small, the copy will happen very quickly and the progress indicator 
may not be needed. 

File Groups: The application and data files to be installed are configured here. You 
select one or more files from the Windows file explorer and drag and drop them into 
the files group tree. To delete an item, select it and press the delete key. The windows 
file explore can be launched from the "Locate files then drag-n-drop" button. 
 
Device files are files that are transferred by the Palm built-in conduit. These have the 
extensions PRC and PDB. 
 
CASL data files are files that are transferred by the CASL conduit and have the 
extensions CDB and CDI. The CASL data files will only be transferred if a CASL 
application is present on the PDA. This means it will take two syncs to get the files 
transferred. The first will transfer the application and the second will transfer the CASL 
data files.  
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A folder called Desktop Files has been added to the File Groups tab in the Application 
Installer feature. You can put any group of files in the folder. These files will be copied 
to the MyApp_PalmOS_Install (and PocketPC) folder but will not be installed on the 
PDA. 

Synchronization: The CASL conduit for PalmOS and PocketPC can optionally be 
installed if the "Install the conduit" checkbox is marked. If it is installed then the user 
installing the application will be shown a dialog box that indicates the synchronization 
manager will be reset so that the new conduit is made ready. 
 
The application creator ID is set to the applications ID if the application data files are 
set to use its ID, otherwise the ID is set to CASL. The Project->Application Settings-
>Database creator ID checkbox is used to set this. 
 
The name shown during synchronization is defined here and so is the directory name 
that is used to create the application directory under the user's synchronization 
directory. These are set to CASL if the application is not using its own creator ID for 
the data files.  

Build: After making changes to the install or if you rebuilt your application, the "Build 
Install" button is used to create a CASLinstall package. The files are placed in a 
directory under your project directory and are named <project name>_install. You 
would give all of the files in this directory to your user and instruct them to execute 
Setup.exe. 
 
NOTE: All of the files in the <project name>_install directory are deleted before the 
build is performed. 
 
Pressing the “Test Install” button can test the install. The CASLinstall is executed and 
the files are installed. 

Features specific to PocketPC installs 
The CASL application installer has been updated to support PocketPC installs. The 
build configuration (i.e. Pilot Release, PocketPC Release, etc.) is used to determine 
the install type. The install files are put into a folder, which has the project name, 
followed by the build type and then “_Install”. For example, a project named PutFrame 
would have a folder called “PutFrame_PocketPC_Install” that contained the PocketPC 
install files. 
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When the application is installed on the device it is stored in a folder under the 
\Program Files folder and is named using the name specified in the Application Name 
field on the Application Information tab. A shortcut is added to the Programs start 
menu folder and is named using the desktop name specified by the Project-
>Application Settings dialog (used to be called Application Settings). If a desktop 
name is not specified, then the Application Name field on the Application Information 
tab will be used. 

There is a new field on the Application Information tab, which allows specifying an 
application icon. If the field is blank, then the standard CASL icon will be used. The 
Icon must contain a 32x32 and 16x16 bit icon and use no more than 256 colors. You 
will need to reset your PocketPC device if you change icons since PocketPC caches 
the old icon image. 

Icon editors can be found on the web. Here are a couple of links: 

 http://www.webattack.com/Freeware/gmm/fwicontools.shtml 

http://home.kabelfoon.nl/~meijer/software/icoedit.html 

http://www.webattack.com/download/dlsnicoedit.shtml 

The directory used by CASL ActiveSync is specified when the application is installed. 
This can be set when setup.exe is run by using the –SyncDataPath option: 

Setup.exe –SyncDataPath “C:\MyApp\SyncData” 

The application data folder edit box will not be displayed on the install application 
dialog. 

A check box labeled Create CAB Files has been added to Build tab which allows 
generating the cab files when the application setup files are produced. If this box is not 
checked, then after the install package is built, you will need to double click the 
buildcab.bat file in the install folder to create the PocketPC CAB files. Double click 
buildcab_cleanup.bat to remove the temporary files. 

The buildcab process combines the CASLppc runtime, application file CCE’s, and 
application dll’s and produces a CAB file for each CPU type. The CeAppMgr.exe 
installer uses these CAB files to install your application on the target device. 

The install includes a copy of CASLppc, which it renames to the application name. 
There is a copy in the ARM, MIPS and SH3 folders. 

http://www.webattack.com/Freeware/gmm/fwicontools.shtml
http://home.kabelfoon.nl/~meijer/software/icoedit.html
http://www.webattack.com/download/dlsnicoedit.shtml
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 NOTE: The following files must be in your CASL 4.1 folder for buildcab to work: 

Makecab.exe 

cabwiz.ddf 

Cabwiz.exe 

These are included with the PocketPC emulator and also can be found at 
http://www.sundialsoft.freeserve.co.uk/cabwiz.zip. 

These are the files that are used by buildcab.bat to produce the CAB and DAT files 
used by CeAppMgr.exe to install your application: 

ARM folder Contains the renamed CASL runtime and needed 
CASL DLL’s and application DLL’s for the ARM 
CPU. 

MIPS folder Contains the renamed CASL runtime and needed 
CASL DLL’s and application DLL’s for the MIPS 
CPU. 

SH3 folder Contains the renamed CASL runtime and needed 
CASL DLL’s and application DLL’s for the SH3 CPU. 

SetupDll.dat Used by the CASL setup DLL when installing and 
uninstalling the application. 

<Your app>.inf Used by cabwiz to create the CAB and DAT files 
used by CeAppMgr.exe to install the application. 

*.CCE Application program files. 

*.WAV Wave files used by the application. 

Buildcab.bat deletes the files that are no longer needed after the CAB files are 
created. The remaining files are used to install your application. These are: 

*.CDB and *.CDI Initial application database files. 

*.CAB and *.DAT Application files installed by CeAppMgr.exe. 

C:\Program
http://www.sundialsoft.freeserve.co.uk/cabwiz.zip
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<Your app>.ini Used by CeAppMgr.exe to install CAB files. 

InstallScript.ini Used by CASL Setup.exe. 

*.TXT Text messages displayed at install time. 

Setup.exe CASL installer. 

The application database files are removed when the application is uninstalled. 
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Automating CASLide Builds 
Builds can now be done from the CASLide command line or batch file. The command 
line options are: 

 -Project “path name for the project CPJ” 

 -Build “build type” where build type is PalmOS Release, PocketPC Release, etc. 

 -Log “path name for log file” 

 -Variable “strvar=\”a string\”” or –Variable “numvar=123” 

 -BuildInstaller 

The –Project option is followed by the path to the project CPJ file. The path must be in 
quotes. 

The –Build option is followed by a string that specifies what target platform to build. 
The valid options are: 

 PalmOS Release 

 PalmOS Debug 

 PocketPC Release 

 PocketPC Debug 

 Windows Release 

 Windows Debug 

The –Log option is followed by the path name for the log file.  The string ***Build 
Error*** will be in the log if the build failed and the CASLide exit code will be –1 
(normally it is 0). 
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The –Variable option allows changing a Project Variable from the command line. The 
parameter that follows the -Variable option is the Project variable and its value. This 
must be in quotes. If the variable value is a string, then the value must also be in 
quotes using the \” to represent the quote. You can repeat the Variable option as many 
times as needed to pass in different variables.  The Variable option will only substitute 
values for Project Variables (i.e. variables defined using the CASLide menu 
Project>Project Variables…) that already exist in the project. 

The following –Variable option sets the string project variable strval to “a string”: 

-Variable “strvar=\”a string\”” 

The following –Variable option sets the numeric project variable to 123: 

–Variable “numvar=123” 

The –BuildInstaller option will build the application installer. This option is only valid for 
PalmOS and PocketPC build types. The application installer must have been 
previously created using the CASLide menu Project->Application Install Settings… 

An example of how to automate the CASLide build process can be found on 
WAGWARE Systems CASL Development page 
http://www.wagware.com/casl_devl.htm. 

http://www.wagware.com/casl_devl.htm
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High Resolution PalmOS Graphics 
The runtime form size can be specified for PalmOS and Windows. The Runtime Form 
Size is set using the Project->Applications Settings dialog. Separate settings are 
maintained for each platform type. 

The IDE Form Size is set using the Tools->IDE Settings dialog. This sets the form size 
for designing forms and is independent of the platform type. 

If you plan on writing your application for hires, double the size of the bitmaps and 
change the CASL display size to 320x320. For example if you had a 50x50 bitmap, 
make it 100x100 to get more detail. You may also have to go through the application 
code and edit the values for x_pos, y_pos, height, and width of controls and draw 
command coordinates where they are changed at runtime.  

Set the runtime form size to 320x320 (hires) and build the project. 

On a hires PDA you will get the hires graphics and on lowres you should see what you 
would see if you did not use hires.  

You could also take advantage of the larger screen area for more display objects in 
hires, but in lowres the objects will be crowded. 

Here is a method to prepared a basic image for hires: 

1. Open an existing CASL bitmap, switch to the Black and White version if you're 
not already on it. 

2. Press Ctrl+A to select it, and Ctrl+C to copy the bitmap. 

3. Open Windows Paint, press Ctrl+V to paste it in. 

4. Save it, because your B/W version in CASL will be lost soon. 

5. Return to CASL bitmap, switch to the Color version of your bitmap. 

6. Press Ctrl+A to select it, and Ctrl+C to copy the bitmap. 

7. Switch to Windows Paint, pressed Ctrl+V to paste it in. 

8. Select Image>Stretch/Skew and stretch horizontal and vertical to 200%. 
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9. Use the Paint editor to touch up the bitmap as needed. You can take out a lot of 
jagged edges. Remember, going from 160 x 160 resolution to 320 x 320 does 
not double your number of pixels, it quadruples it. You go from 25,600 pixels to 
102,400. So you can really improve things. 

10. When your image looks nice, press Ctrl+A, Ctrl+C to copy the image. 

11. Return to CASLide, select Image>Bitmap properties... and double the size of 
your color bitmap. This is where your old bitmap (color and bw) disappears. 

12. Press Ctrl+V to paste the new bitmap in. 

13. Return to Paint and open the B/W version you saved. 

14. Repeat steps 8-10(+12) for the B/W version then save it in CASL. 

15. Repeat all this for each bitmap in your project. 

Support for large and small icons has been added for PalmOS. When you create an 
icon you will be prompted for a small or large icon. 

screen desktop icon list icon 

low-res 22x22 15x9 

hi-res 44x44 30x18 

 

NOTE: The previous PalmOS project icon is not compatible with CASL 4.3 and will 
have to be recreated to fit the new size. 

Palm has changed icon sizes so your old icons will have to be removed from your 
project and recreated. You'll need to open CASL43, open your current icon there, copy 
it to the clipboard and move back to Window Paint to save it (and save the B/W 
version of your icon too). You have to save it because the old icon has to be removed 
from your project when you open the project in CASL42. The old icon won't open in 
CASL42 since it's the wrong dimensions. So remove it, then add a new icon for your 
project, and select to make it a desktop icon. 

Your large hi-res icon (CASL calls it a desktop icon) will be 44x44. They're square now 
rather than rectangular like in low res.  
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You old icon was 32 x 22, so your height is going to double but you'll have to cut the 
width back from 32 to 22, so when you double the bitmap size it will fit in 44 x 44. 
Takes some playing with, depending on your current icon's width, to make a new one 
resized to the right dimensions. 

Your new small, list-sized icon will be 30 x 18. Palm has given a different shape here 
so you can't just reduce the large icon by 50%. 

Once you have your small icon created in Paint, copy it, add a List icon to your project 
in CASLide and paste the small icon in. (repeat for B/W small icon). 

NOTE: You will need the newer Palm OS5 SDK, which can be downloaded from: 

http://www.caslsoft.com/download/palmos-sdk-5.0r3-1.tar.gz 

If you do not use it you will get a “MemGluePtrNew not found” error during the PRC 
creation process. 

http://www.caslsoft.com/download/palmos-sdk-5.0r3-1.tar.gz
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PocketPC ActiveSync for CASL 
Before using CASL ActiveSync, the application database must first be opened and 
closed using the new CASL PocketPC runtime for the database to be upgraded to 4.3.  

The CASLcdi2ppc and CASLppc2cdb utilities are no longer used. 

CASL ActiveSync only supports sync modes merge and none. However CDI files are 
still used to create an initial database on the PDA. 

Introduction 
CASL Active Sync is used to synchronize CASL database files on Pocket PC (PPC) 
(running Microsoft Windows CE) handheld PDA’s with .CDB/.CDI files on your 
Microsoft Windows PC. 

When you place your PPC into its docking cradle the Windows Active Sync Manager 
recognizes it initiates the transfer of new, edited or deleted records from either the 
PPC and/or windows.  You will need to have installed version 3.7.1 or later of Microsoft 
ActiveSync. 

When you install your CASL application onto your PPC you are also asked to define a 
directory on your PC where that application (by creatorID) where the PC side 
.CDB/.CDI files will reside. 

Behaviors of ActiveSync: 
 The PPC application cannot have the database open when the PC is trying to 

update the database. You will get a message indicating that there are 
unresolved items. 

 When you update a database on the PPC, then ActiveSync detects that the 
database has changed and will automatically synchronize the database if the 
desktop schedule (Options->Schedule) is not set to “manually”. The PC will not 
see the change if the file is open during the synchronization. 

 You cannot synchronize databases between PalmOS and PocketPC because 
the record id’s are produced using different methods. 
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 Deleting the database files on the PC will not delete the database on the PPC. 
The database will be recreated if you perform a sync and then disconnect and 
reconnect. 

 CASLsync will ONLY synchronize a single PPC to a single PC! 

Installation 
A new synchronization tab has been added to the PocketPC installer dialog. For your 
application, enter the name that you wish to be shown in the ActiveSync options 
screen. The “Install the conduit” checkbox must be checked for CASL ActiveSync to 
be installed with the application. 

Setup.exe allows overriding the sync data path when the –SyncDataPath option is 
specified: Setup.exe –SyncDataPath “C:\MyApp\SyncData”. The application data 
folder edit box will not be displayed on the install application dialog. 

After the application is installed, an entry for the application will be displayed in the 
ActiveSync options screen. Enable CASL ActiveSync by checking the application icon 
in the ActiveSync options screen. Each application will have its own CASLsync icon.  

CDI files that are included in the install configuration and will be transferred to the PDA 
when the sync is performed (similar to PalmOS HotSync). 

If an application is uninstalled from the PPC then its CASL ActiveSync configuration 
should also be removed. Open ActiveSync and select the Options menu. On the Sync 
Options tab, select the application and the click the Settings button. A dialog will be 
displayed that will allow removing the application’s CASL ActiveSync setting. 

Optionally, the utility CASLremas can be used to remove a CASL ActiveSync provider. 
There are two optional command line arguments: 

-CreatorID id 
 
Id is the application creator ID. If you do not specify -Creator ID, then the CASL entry 
will be removed. 

-Silent 
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Using this will remove the prompt that asks if you are sure you want to remove the 
ActiveSync provider and will remove the prompt that indicates the ActiveSync provider 
has been removed. Error prompts will still be shown. 

Here is an example: 

CASLremas -CreatorID FRED -Silent 

This will remove the CASL ActiveSync provider FRED. 

Important Note for selecting the CASL ActiveSync Directory! 

You cannot have two different applications (creatorIDs) using the same CASL 
ActiveSync directory!  This is because the .CDB/.CDI files do NOT have the 
creatorID in them.  Therefore CASLsync cannot determine the difference between one 
.cdb or another by creatorID.  Thus CASLsync would try to synchronize all files in the 
directory multiple times, once for each application configured in the directory. 

Also, because of this new PPC databases (from .cdi files) would not be assigned to 
the correct application (by creatorID) in the PPC. 

Also, you CANNOT use the same directories to synchronize PALM and PPC 
databases. 

Configuring Microsoft ActiveSync Manager 
When you place your PPC into its docking cradle, the Microsoft ActiveSync application 
will run. 

Before performing CASL ActiveSync you must enable those CASL applications to be 
synchronized.  To do this press the options button on the toolbar of the Microsoft 
ActiveSync application. 
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Selecting Applications for Synchronization 

This brings up a dialog box with three tabs.  Select the “Sync Options” tab.  You will 
see a list of applications that ActiveSync has knowledge of with check boxes next to 
them.  The CASL applications are indicated by the CASL icon and having a name of 
CASL: <application name>.  If you want ActiveSync to synchronize an application click 
in the check box to the left of its icon and a check mark should appear. 

If the application does not exist in the list or it does not have a check box then CASL 
ActiveSync for that application has not been installed or something failed in its install. 

Setting Synchronization Method (On Connection or Manual) 

Now select the schedule tab of the options dialog box.  In the Desktop Schedule 
section select “On Connection”.  You my select “Manually” but this means that you 
must press the “Sync” button on the main window to actually perform the 
synchronization. 

Do not select “Continuously” when CASL applications are selected for synchronization 
as CASL ActiveSync has NOT been optimized for continuous synchronization. 

Once you have selected your Desktop Schedule, press the OK button.  This will cause 
the ActiveSync application to begin synchronization with the selected application(s).  If 
you selected “On Connection”, the synchronization will be run.  If you selected 
“Manually”, the synchronization will just collect information on the number of items not 
synchronized for each application selected.  Pressing the “Sync” button completes the 
synchronization. 

Synchronization of CASL Databases 
You can now perform normal synchronizations of your PPC databases with the PC. 

Whenever you wish to synchronize your PPC with the PC, simply place it into its 
docking cradle.  The Microsoft AcitveSync Manager application will run and perform 
the synchronization (as described at the end of the previous section). 

After synchronization has completed you can remove the PPC.  (Or leave it connected 
to recharge the battery.) 
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The ActiveSync Manager continues to run as long as the PPC is installed.  Any record 
that change on the PPC will be noted as items not synchronized in the application’s 
display.  You can press the Sync button again to synchronize these.  CASLsync does 
NOT keep track of records that have changed in the PC side database.  However, 
when you press the sync button, the PC side records will be re-read and synchronized 
if necessary. 

PC CASL ActiveSync Database Files (.cdb/.cdi) 
CASLsync uses the same format database files as used by CASL’s Palm HotSync.  
These consist of files in the application’s Caslsoft® ActiveSync directory with .cdb and 
.cdi extensions.  The name of the database file in the PPC is the same as the .cdb/.cdi 
file without the .cdb/.cdi extension. 

The .cdb files are the usual place for database information to be stored in the PC.  If 
an application’s database exists on the PPC but not on the PC, the .cdb file for it will 
be created.  Note: the .cdb file will NOT be created until there is at lease one 
record in the PPC database. 

If the .cdb file is deleted from the PC (erroneously) it will be recreated after TWO full 
synchronization cycles (removing and replacing of the PPC from its docking cradle). 

If a .cdb file has no existing database on the PPC, its #SYNCMODE parameter is 
forced to “NO_SYNC” (see #SYNCMODE setting section below) and will not be 
synchronized. 

The .cdi files are used to force initial database records down the PPC.  Only .cdi files 
can be used to create new database files on the PPC.  If a database already exists on 
the PPC for the .cdi file, it is deleted and replaced by the new information.  After the 
data from the .cdi files are synchronized to the PPC, the .cdi file is renamed to .cdb. 

You can rename a .cdb file to .cdi to force its information down to the PPC without 
regard of the information in the PPC database. 

When the synchronization process has completed, the previous .cdb/.cdi file will be 
renamed with a .bak extension and a new .cdb file is created (assuming something 
changed). 



                                                                                                                      CASLide 
Version 4.3 

 107

#SYNCMODE setting 

The .cdb file has a number of parameters within it.  The #SYNCMODE parameter is of 
special use by CASLsync.  This parameter is used to decide if a file is to be 
synchronized or not or how to resolve changed record conflicts (the same record is 
changed in both the PC and PPC side database). 

The following give the useful values for the #SYNCMODE parameter: 

NO_SYNC Do not synchronize this file 

MERGE Synchronize, manually resolve changed record conflicts 

PDA_TO_PC Synchronize, PDA records are always used in conflicts 

PC_TO_PDA Synchronize, PC    records are always used in conflicts 

A dialog box displayed by the ActiveSync Manager program handles manually 
resolved conflicts. 

There is a SYNCMODE associated with the PPC database as well.  That SYNCMODE 
has priority and if they do not match, the .cdb file’s SYNCMODE will be changed to 
match. 

Log Files 
CASLsync creates log files of its operations on both the PC and PPC.  These log files 
are an invaluable tool in diagnosing any problems that might crop up (to be read by 
CASL tech support only).  These files should be sent with any bug report that you 
might have about CASLsync. 

The log files come in sets of two.  On the PC they are called caslsync.log and 
caslsync_1.log and reside in the logged in user’s temp directory in the CASL 
subdirectory.  On the PPC they are called casldev.log and casldev_1.log and reside in 
the /temp directory. (The casldev.log files are forced to be only 50K bytes long to keep 
from hogging the PPC memory.) 

To get the PPC log files you use the Explore tool bar button from the ActiveSync 
Manager application.  Select “My Pocket PC” and then select the Temp directory.  You 
must COPY the log files out of this directory into another before you can access them 
to be sent to CASL. 
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How to Get More Information 
Check our web site for additional CASL web sites, mail lists, FAQ’s, updates, and new 
releases. 

The CASLsoft home web site is http://www.caslsoft.com 

The support site is http://www.caslsoft.com/support.htm 

The support message board is http://www.caslsoft.com/phpBB2 

Helpful links to other sites is http://www.caslsoft.com/links.htm 

Download the latest release from http://www.caslsoft.com/download.htm 

 

http://www.caslsoft.com
http://www.caslsoft.com/support.html
http://www.caslsoft.com/phpBB2
http://www.caslsoft.com/links.html
http://www.caslsoft.com/download.html
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